aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-coreschema
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 08:54:32 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 09:05:48 -0300
commit0e9ffaad05e7d5e666f35cef9a716f96789e64e8 (patch)
tree490561d3b9c9ea4de90184a9950c71035f7d4e7e /testing/py-coreschema
parent6193383f6b099af15cec504716adcdf88d90c56d (diff)
downloadaports-0e9ffaad05e7d5e666f35cef9a716f96789e64e8.tar.bz2
aports-0e9ffaad05e7d5e666f35cef9a716f96789e64e8.tar.xz
testing/py3-coreschema: rename from py-coreschema
Diffstat (limited to 'testing/py-coreschema')
-rw-r--r--testing/py-coreschema/APKBUILD59
-rw-r--r--testing/py-coreschema/use-system-py-test.patch5
2 files changed, 0 insertions, 64 deletions
diff --git a/testing/py-coreschema/APKBUILD b/testing/py-coreschema/APKBUILD
deleted file mode 100644
index 3bbce81da3..0000000000
--- a/testing/py-coreschema/APKBUILD
+++ /dev/null
@@ -1,59 +0,0 @@
-# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
-# Maintainer:
-pkgname=py-coreschema
-_pkgname=${pkgname/py/python}
-pkgver=0.0.4
-pkgrel=1
-pkgdesc="No description or topics provided"
-url="https://github.com/core-api/python-coreschema"
-arch="noarch"
-license="BSD"
-depends="py-jinja2"
-makedepends="python2-dev python3-dev py-setuptools"
-checkdepends="pytest"
-options="!check" #currently broken
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-source="$pkgname-$pkgver.tar.gz::https://github.com/core-api/python-coreschema/archive/$pkgver.tar.gz
- use-system-py-test.patch
- "
-builddir="$srcdir"/$_pkgname-$pkgver
-
-build() {
- cd "$builddir"
- python2 setup.py --quiet build
- python3 setup.py --quiet build
-}
-
-package() {
- cd "$builddir"
- mkdir -p "$pkgdir"/usr/bin
-}
-
-check() {
- cd "$builddir"
- ./runtests
-}
-
-_py2() {
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-_py() {
- local python="$1"
- local pyver="${1:6:1}"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py --quiet install --prefix=/usr --root="$subpkgdir"
-}
-
-sha512sums="28badbae07284fb4dbd3f01f613edda1202902115fb166bd95bbac549d398c9e02548b473524d3b530a42319a99d7e55e92bf54269827a9812249cfb285670c3 py-coreschema-0.0.4.tar.gz
-044f95c17094d806e9cacd1bd9d8e358859b24fb0c27f97c47e3dd89f3f16b4151a7b8f47aadfa5e6ca664d185a16e45a947c4a88156a78217f17031191eda14 use-system-py-test.patch"
diff --git a/testing/py-coreschema/use-system-py-test.patch b/testing/py-coreschema/use-system-py-test.patch
deleted file mode 100644
index cc879d9906..0000000000
--- a/testing/py-coreschema/use-system-py-test.patch
+++ /dev/null
@@ -1,5 +0,0 @@
---- a/runtests
-+++ b/runtests
-@@ -1,2 +1 @@
--export PYTHONPATH=.
- py.test tests/ --cov=coreschema --cov-report html