aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-des
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2015-04-16 16:44:46 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2015-05-09 07:40:26 +0000
commitb3704111fffeba2cfff47de433c827222b3719d7 (patch)
tree9f00e35e160f1fe72a12ecd806248e1173e2629b /testing/py-des
parent933c4cc14eeb958c80a34eb1cbf2a2474fae4e11 (diff)
downloadaports-b3704111fffeba2cfff47de433c827222b3719d7.tar.bz2
aports-b3704111fffeba2cfff47de433c827222b3719d7.tar.xz
testing/py-des: new aport
Pure python implementation of DES and TRIPLE DES encryption algorithm http://twhiteman.netfirms.com/des.html
Diffstat (limited to 'testing/py-des')
-rw-r--r--testing/py-des/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-des/APKBUILD b/testing/py-des/APKBUILD
new file mode 100644
index 0000000000..6ff5dcc966
--- /dev/null
+++ b/testing/py-des/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-des
+_pkgname=pyDes
+pkgver=2.0.1
+pkgrel=0
+pkgdesc="A Python implementation of DES and TRIPLE DES encryption algorithms"
+url="http://twhiteman.netfirms.com/des.html"
+arch="noarch"
+license="MIT"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://twhiteman.netfirms.com/pyDES/$_pkgname-$pkgver.zip"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="90f06a24a1ee73fb0e235571d51c287a pyDes-2.0.1.zip"
+sha256sums="9cc6e509f627ef1c2d318730d22f1a33f23b41e1ec223b55a6420f2861266d76 pyDes-2.0.1.zip"
+sha512sums="d9107d532801ff2eb096eeb606c1b81fd68a76fccffdf095a6a2a79bd19815b4c366549989b6f4508c99a2f9afb063eceb7b0702e504ebb4d73dc8175057cb28 pyDes-2.0.1.zip"