aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-django-mptt/APKBUILD
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-12-20 08:39:30 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-12-21 10:53:18 +0000
commit725fe04b242d8b89cdc825bc9cdd14cea9189030 (patch)
treee429a5fdcdd81bc720121b5147f81c3617d19ece /testing/py-django-mptt/APKBUILD
parent58412f1c9e877d5e506bfe54432f07569fb1ed6f (diff)
downloadaports-725fe04b242d8b89cdc825bc9cdd14cea9189030.tar.bz2
aports-725fe04b242d8b89cdc825bc9cdd14cea9189030.tar.xz
testing/py-django-mptt: new aport
Diffstat (limited to 'testing/py-django-mptt/APKBUILD')
-rw-r--r--testing/py-django-mptt/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/testing/py-django-mptt/APKBUILD b/testing/py-django-mptt/APKBUILD
new file mode 100644
index 0000000000..7d6b2b15c4
--- /dev/null
+++ b/testing/py-django-mptt/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer:
+pkgname=py-django-mptt
+pkgver=0.9.0
+pkgrel=0
+pkgdesc="Utilities for implementing a modified pre-order traversal tree in django"
+url="https://github.com/django-mptt/django-mptt"
+arch="noarch"
+license="Custom"
+depends="py-django py-django-js-asset"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="$pkgname-$pkgver.tar.gz::https://github.com/django-mptt/django-mptt/archive/$pkgver.tar.gz"
+options="!check" #no testsuite provided
+builddir="$srcdir"/django-mptt-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py --quiet build
+ python3 setup.py --quiet build
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir"/usr/bin
+}
+
+_py2() {
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ local pyver="${1:6:1}"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py --quiet install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="7a5356b4c2a242f716b3b481d318b2a5741817fd40b79f54ec5a74fcc3cc0e4469c0a28601b3139cebc9a5ec4da0ef8f4f24476065fc8230fb8de94343852000 py-django-mptt-0.9.0.tar.gz"