aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-django-taggit
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2018-08-22 12:49:05 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-08-22 13:11:34 +0000
commita1811fcf40388c88cf903dada558622e534a2b25 (patch)
treedadc70d0e13c466db3d412e0ffa3fffab213e769 /testing/py-django-taggit
parent1e9764994323fecc78772a1035cc7f4380e7f63d (diff)
downloadaports-a1811fcf40388c88cf903dada558622e534a2b25.tar.bz2
aports-a1811fcf40388c88cf903dada558622e534a2b25.tar.xz
testing/py-django-taggit: new aport
Simple tagging for Django
Diffstat (limited to 'testing/py-django-taggit')
-rw-r--r--testing/py-django-taggit/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/testing/py-django-taggit/APKBUILD b/testing/py-django-taggit/APKBUILD
new file mode 100644
index 0000000000..5e666e0150
--- /dev/null
+++ b/testing/py-django-taggit/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer:
+pkgname=py-django-taggit
+pkgver=0.22.2
+pkgrel=0
+pkgdesc="Simple tagging for django"
+url="https://github.com/alex/django-taggit"
+arch="noarch"
+license="BSD-3-Clause"
+depends="py-django"
+makedepends="python2-dev python3-dev py2-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+options="!check" # no test suite
+source="$pkgname-$pkgver.tar.gz::https://github.com/alex/django-taggit/archive/$pkgver.tar.gz"
+builddir="$srcdir"/django-taggit-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py --quiet build
+ python3 setup.py --quiet build
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir"/usr/bin
+}
+
+_py2() {
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ local pyver="${1:6:1}"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py --quiet install --prefix=/usr --root="$subpkgdir"
+}
+
+
+sha512sums="3363ee30ea811b997648e1f586480a2608e28d585fcbc7f61932467081101baa6112b61f1a254f080879432d7b57ef33ad543e12ad7aa17df36c8c283bf896f2 py-django-taggit-0.22.2.tar.gz"