aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-django-timezone-field
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2018-03-05 08:26:41 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-03-05 08:27:18 +0000
commit9a7403132f4ee035a4ab2b12c5b4e7fa6382bd21 (patch)
treece3682cbe100b83fdc32c8fe72c2839452cee340 /testing/py-django-timezone-field
parent792ba63de2979a133ded301ebb0ca5a9987aa6f5 (diff)
downloadaports-9a7403132f4ee035a4ab2b12c5b4e7fa6382bd21.tar.bz2
aports-9a7403132f4ee035a4ab2b12c5b4e7fa6382bd21.tar.xz
testing/py-django-timezone-field: new aport
Diffstat (limited to 'testing/py-django-timezone-field')
-rw-r--r--testing/py-django-timezone-field/APKBUILD55
1 files changed, 55 insertions, 0 deletions
diff --git a/testing/py-django-timezone-field/APKBUILD b/testing/py-django-timezone-field/APKBUILD
new file mode 100644
index 0000000000..9ea416dac0
--- /dev/null
+++ b/testing/py-django-timezone-field/APKBUILD
@@ -0,0 +1,55 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer:
+pkgname=py-django-timezone-field
+pkgver=2.1
+pkgrel=0
+pkgdesc="A Django app providing database and form fields for pytz timezone objects"
+url="https://pypi.python.org/pypi/django-timezone-field"
+arch="noarch"
+license="BSD"
+depends="py-django py-tz"
+makedepends="python2-dev python3-dev py-setuptools"
+options="!check" #no testsuite
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="$pkgname-$pkgver.tar.gz::https://github.com/mfogel/django-timezone-field/archive/2.1.tar.gz"
+builddir="$srcdir"/django-timezone-field-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py --quiet build
+ python3 setup.py --quiet build
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir"/usr/bin
+}
+
+check() {
+ cd "$builddir"
+ python2 tests.py
+ python3 tests.py
+}
+
+_py2() {
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ local pyver="${1:6:1}"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py --quiet install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="2a6334bcaae39c8b5f214e97edc9d3214a8f408cc12d54748497585c8b69227a88d2b757ab4800e18f904f87ab86a0063acb1b533c9b2d0d92bf486388f9d441 py-django-timezone-field-2.1.tar.gz"