aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-filelock
diff options
context:
space:
mode:
authorDmitry Romanenko <Dmitry@Romanenko.in>2019-01-22 20:04:58 -0500
committerAndy Postnikov <apostnikov@gmail.com>2019-01-24 18:03:54 +0200
commite03e40f33cfca10bacdadaaee938dca24352403e (patch)
tree8a817a22c7d7cb04712c54db22fc88bd67b5e9db /testing/py-filelock
parent706da36557f9c5d773a4c2753a10ffef7fda9d3b (diff)
downloadaports-e03e40f33cfca10bacdadaaee938dca24352403e.tar.bz2
aports-e03e40f33cfca10bacdadaaee938dca24352403e.tar.xz
testing/py-filelock: new aport
Diffstat (limited to 'testing/py-filelock')
-rw-r--r--testing/py-filelock/APKBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/testing/py-filelock/APKBUILD b/testing/py-filelock/APKBUILD
new file mode 100644
index 0000000000..355c91706b
--- /dev/null
+++ b/testing/py-filelock/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Dmitry Romanenko <dmitry@romanenko.in>
+# Maintainer: Dmitry Romanenko <dmitry@romanenko.in>
+pkgname=py-filelock
+_pkgname=filelock
+pkgver=3.0.10
+pkgrel=0
+pkgdesc="A platform independent file lock for Python"
+url="https://github.com/benediktschmitt/py-filelock"
+arch="noarch"
+license="Unlicense"
+depends=""
+checkdepends="pytest"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py3-$_pkgname:_py3 py2-$_pkgname:_py2"
+source="$pkgname-$pkgver.tar.gz::https://github.com/benediktschmitt/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python2 -m pytest -xvv test.py
+ python3 -m pytest -xvv test.py
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="1fa4594eaba6689ea61149a60a71e86007297614a1c22dc6c94b4774520d396ff8ad03076dfdbb2ce49d2b6e42c374af065a115c167d81cf6107918abfbe52ef py-filelock-3.0.10.tar.gz"