aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-flake8-class
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2016-11-08 22:46:08 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-12-27 10:25:27 +0200
commit91dd364411cdcc1f2df495cb63947d305de4cf42 (patch)
tree368bef7d44aaaea7f09d4479c28f619685c41066 /testing/py-flake8-class
parent94a07a6fdd1e1e92ae3d477805cd4f22d3c53d28 (diff)
downloadaports-91dd364411cdcc1f2df495cb63947d305de4cf42.tar.bz2
aports-91dd364411cdcc1f2df495cb63947d305de4cf42.tar.xz
testing/py-flake8-class: new aport
Flake8 lint for class declaration. https://github.com/hellysmile/flake8-class
Diffstat (limited to 'testing/py-flake8-class')
-rw-r--r--testing/py-flake8-class/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py-flake8-class/APKBUILD b/testing/py-flake8-class/APKBUILD
new file mode 100644
index 0000000000..f4990e5ba3
--- /dev/null
+++ b/testing/py-flake8-class/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-flake8-class
+_pkgname=flake8-class
+pkgver=0.0.6
+pkgrel=0
+pkgdesc="Extension for flake8 lint of class declations"
+url="https://github.com/hellysmile/flake8-class"
+arch="noarch"
+license="MIT"
+depends="flake8"
+makedepends="python3-dev"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="2985f994e54d1fe5a96f9e7362e7dac7 flake8-class-0.0.6.tar.gz"
+sha256sums="945bdb688ef892a2eff2a148c5a271342f85d2ea7ac30e5f52ccaeaf38262260 flake8-class-0.0.6.tar.gz"
+sha512sums="453c994bdb98921dc384ead1373fc455ac664273c3a9fb6c05485f40abb44e9120597e7f54541a72c3a1cca4a634188771379def722dd20b7f28bf95cbf85636 flake8-class-0.0.6.tar.gz"