aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-flake8-commas
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2016-11-08 23:09:24 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-12-27 10:25:27 +0200
commit99e498506ce16c4ecea70900c6ecb67e4539187e (patch)
tree9b77b88b3abbdc35d70eab3c4bca804dbdce856d /testing/py-flake8-commas
parent36c2188d29b30aa6ca9c9a26e4b91847139b0066 (diff)
downloadaports-99e498506ce16c4ecea70900c6ecb67e4539187e.tar.bz2
aports-99e498506ce16c4ecea70900c6ecb67e4539187e.tar.xz
testing/py-flake8-commas: new aport
Extension for flake8 to enforce trailing commas https://github.com/trevorcreech/flake8-commas
Diffstat (limited to 'testing/py-flake8-commas')
-rw-r--r--testing/py-flake8-commas/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py-flake8-commas/APKBUILD b/testing/py-flake8-commas/APKBUILD
new file mode 100644
index 0000000000..4a2c6d7c07
--- /dev/null
+++ b/testing/py-flake8-commas/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-flake8-commas
+_pkgname=flake8-commas
+pkgver=0.1.6
+pkgrel=0
+pkgdesc="Extension for flake8 to enforce trailing commas"
+url="https://github.com/trevorcreech/flake8-commas"
+arch="noarch"
+license="MIT"
+depends="flake8"
+makedepends="python3-dev"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="59b931936b1b01d4968d21415ac62fc1 flake8-commas-0.1.6.tar.gz"
+sha256sums="05d7a232746bffd3a2e1d9f6992d7fea6abe3e6b5b2864c40070621270e70be2 flake8-commas-0.1.6.tar.gz"
+sha512sums="2631544ea55a704e9b9d1cfbcb05eb11f15afaba3e521e10f23f45b2f2f4d79ad3da0bf596cf23917eaafdd5f6eecd111704b86578b70bae441cf868e6dc2885 flake8-commas-0.1.6.tar.gz"