aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-flake8-quotes
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2016-11-08 23:02:21 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-12-27 10:25:27 +0200
commit7a19e9a078d8ebf7bd150b8f722141847e4112c8 (patch)
tree7f5f4662e72557dad4de92ba1651277e9a3b8408 /testing/py-flake8-quotes
parentf52cfe79d5061a0acaeada55dadc73148b1e0ca1 (diff)
downloadaports-7a19e9a078d8ebf7bd150b8f722141847e4112c8.tar.bz2
aports-7a19e9a078d8ebf7bd150b8f722141847e4112c8.tar.xz
testing/py-flake8-quotes: upgrade to 0.8.1
Diffstat (limited to 'testing/py-flake8-quotes')
-rw-r--r--testing/py-flake8-quotes/APKBUILD37
1 files changed, 12 insertions, 25 deletions
diff --git a/testing/py-flake8-quotes/APKBUILD b/testing/py-flake8-quotes/APKBUILD
index 597122375a..7603871a07 100644
--- a/testing/py-flake8-quotes/APKBUILD
+++ b/testing/py-flake8-quotes/APKBUILD
@@ -2,40 +2,27 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py-flake8-quotes
_pkgname=flake8-quotes
-pkgver=0.0.1
-pkgrel=1
+pkgver=0.8.1
+pkgrel=0
pkgdesc="Extension for flake8 which lint for double quotes"
url="http://github.com/zheller/flake8-quotes/"
arch="noarch"
license="MIT"
-depends="python2 flake8"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
+depends="flake8"
+makedepends="python3-dev"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$_builddir"
- python2 setup.py build || return 1
+ cd "$builddir"
+ python3 setup.py build || return 1
}
package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
}
-md5sums="aafef6c6cca7462c1dfdd86912624ac3 flake8-quotes-0.0.1.tar.gz"
-sha256sums="6f94471ec583b0de7b8b6c5d3859b8cedd48da23b66bad16a8ce1140d6f80447 flake8-quotes-0.0.1.tar.gz"
-sha512sums="2f49f410c8e3979357df99b95057c1f5309b2eb28493680189bd2d587f39a1207de76a6679e3bc1ea73143268c6fba600b455c1c69615a72a9c51de3395983c8 flake8-quotes-0.0.1.tar.gz"
+md5sums="f04c699da47d41c1bf4cb532072d17b6 flake8-quotes-0.8.1.tar.gz"
+sha256sums="668ec2fb0fbf1574a95f49e393364f8a114c7180e5cedc7377c5f4b5257e00fb flake8-quotes-0.8.1.tar.gz"
+sha512sums="f90182798817b88bbf72d7966498e5d2b37e0b2d6ec1e2cecdee69bae8ce582507cd7e3c82a1a9589dfd0bfa9976781280f6c1d51ebc1232a31d6e9a5c34b5e9 flake8-quotes-0.8.1.tar.gz"