aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-flask-auth
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-14 08:10:36 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-09-17 15:01:25 +0000
commit610cbb5fd23de2118b8ec4387e21b280282b3baf (patch)
tree96416a52bf24b08f8e808e1128da3504393473fd /testing/py-flask-auth
parent9fc23db7c7bea42814b3c274cc6fc840abb9b12a (diff)
downloadaports-610cbb5fd23de2118b8ec4387e21b280282b3baf.tar.bz2
aports-610cbb5fd23de2118b8ec4387e21b280282b3baf.tar.xz
testing/py-flask-auth: new aport
Flask auth https://pypi.python.org/pypi/Flask-Auth
Diffstat (limited to 'testing/py-flask-auth')
-rw-r--r--testing/py-flask-auth/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-flask-auth/APKBUILD b/testing/py-flask-auth/APKBUILD
new file mode 100644
index 0000000000..eb8a4c0df6
--- /dev/null
+++ b/testing/py-flask-auth/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-flask-auth
+_pkgname=Flask-Auth
+pkgver=0.85
+pkgrel=0
+pkgdesc="Flask auth"
+url="https://pypi.python.org/pypi/Flask-Auth"
+arch="noarch"
+license="BSD"
+depends="python py-flask"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="92099b3c7ba067890c92ae683105aefd Flask-Auth-0.85.tar.gz"
+sha256sums="a749c1f021a731ba8b40656bf863093840fa8cb4f1d2675571c1073357245285 Flask-Auth-0.85.tar.gz"
+sha512sums="67085b6ffe4f09b1536faf3d656fd066e354919110333319d7355df8bef5aabbc8c5b7aece71d42ae4d579020aa5048341691620412e6508fd993ab89a15c1c5 Flask-Auth-0.85.tar.gz"