aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-flask-bcrypt
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-14 11:28:45 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-09-17 15:01:29 +0000
commit0128ad51b2fbff7c39657722b44aa8ade4f19636 (patch)
treea16f78f346ba2e9d7cfdc3b2bdc5938c0fd0d37f /testing/py-flask-bcrypt
parent6f583d8f8c2e7798079a48fec647e72f746056f2 (diff)
downloadaports-0128ad51b2fbff7c39657722b44aa8ade4f19636.tar.bz2
aports-0128ad51b2fbff7c39657722b44aa8ade4f19636.tar.xz
testing/py-flask-bcrypt: new aport
Flask Bcrypt hashing extension https://pypi.python.org/pypi/Flask-Bcrypt
Diffstat (limited to 'testing/py-flask-bcrypt')
-rw-r--r--testing/py-flask-bcrypt/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-flask-bcrypt/APKBUILD b/testing/py-flask-bcrypt/APKBUILD
new file mode 100644
index 0000000000..dfe22e60fc
--- /dev/null
+++ b/testing/py-flask-bcrypt/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-flask-bcrypt
+_pkgname=Flask-Bcrypt
+pkgver=0.5.2
+pkgrel=0
+pkgdesc="Flask Bcrypt hashing extension"
+url="https://pypi.python.org/pypi/Flask-Bcrypt"
+arch="noarch"
+license="BSD"
+depends="python py-flask"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="0ab56e917cb0cd8e073018038ac9945c Flask-Bcrypt-0.5.2.tar.gz"
+sha256sums="4c8e0d4c9ec10891740362e41242529fec685512591f844489ef45f7e3ff4242 Flask-Bcrypt-0.5.2.tar.gz"
+sha512sums="918d7aa6697e237d4e90a469c03a8ae195109a4a162bf2b9f88392846c129161b89190cda50fffa30d8f0d0dff112886a689243977487bc7810d56cf1b9633f3 Flask-Bcrypt-0.5.2.tar.gz"