aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-flask-cache
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-14 08:31:20 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-09-17 15:01:26 +0000
commit944e72bb4f49c4618f309fcb9896356e585d9f44 (patch)
tree8eb0503fbd9a56d5b093db72736a4d6647947660 /testing/py-flask-cache
parent16a7d41f1b3d42c4191a8c4601245e6a0f2b9cb4 (diff)
downloadaports-944e72bb4f49c4618f309fcb9896356e585d9f44.tar.bz2
aports-944e72bb4f49c4618f309fcb9896356e585d9f44.tar.xz
testing/py-flask-cache: new aport
Flask cache support https://pypi.python.org/pypi/Flask-Cache
Diffstat (limited to 'testing/py-flask-cache')
-rw-r--r--testing/py-flask-cache/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-flask-cache/APKBUILD b/testing/py-flask-cache/APKBUILD
new file mode 100644
index 0000000000..49a0b15c44
--- /dev/null
+++ b/testing/py-flask-cache/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-flask-cache
+_pkgname=Flask-Cache
+pkgver=0.12
+pkgrel=0
+pkgdesc="Flask cache support"
+url="https://pypi.python.org/pypi/Flask-Cache"
+arch="noarch"
+license="BSD"
+depends="python py-flask"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="4bd521a3fb0b4ff02e9d1ff6e88feddf Flask-Cache-0.12.tar.gz"
+sha256sums="4bd7300c8b8f59b4419718ad7ae31025f9fed19f5852b124cf4badfe08d431ad Flask-Cache-0.12.tar.gz"
+sha512sums="8f5062e1950ff9c118268d42e27bb334c88f18c3fba8af6bb738c26ca0b4fb7c14a3c73a50142d714df7d32486857799bd910b6bcc0081aeba6626257c84e483 Flask-Cache-0.12.tar.gz"