aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-flask-ldap
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-14 11:20:46 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-09-17 15:01:29 +0000
commitf1d5234b33bf161ab6c45b1366b65f680c377e04 (patch)
treed8881b7afedbe79db83a34bfff39e20934a2bfa3 /testing/py-flask-ldap
parent2007584c26ca3c5f83da19ec987bb5b0b6b1656e (diff)
downloadaports-f1d5234b33bf161ab6c45b1366b65f680c377e04.tar.bz2
aports-f1d5234b33bf161ab6c45b1366b65f680c377e04.tar.xz
testing/py-flask-ldap: new aport
Flask LDAP extension https://pypi.python.org/pypi/Flask-LDAP
Diffstat (limited to 'testing/py-flask-ldap')
-rw-r--r--testing/py-flask-ldap/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-flask-ldap/APKBUILD b/testing/py-flask-ldap/APKBUILD
new file mode 100644
index 0000000000..5ae154f809
--- /dev/null
+++ b/testing/py-flask-ldap/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-flask-ldap
+_pkgname=Flask-LDAP
+pkgver=0.1.4
+pkgrel=0
+pkgdesc="Flask LDAP extension"
+url="https://pypi.python.org/pypi/Flask-LDAP"
+arch="noarch"
+license="BSD"
+depends="python py-flask"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="bea01b58c63b5600e3487870bf193445 Flask-LDAP-0.1.4.tar.gz"
+sha256sums="37a94a0cdcc3ae653aee31ea09dc226dd7c6127a8ae6f7a8c9d7e61af73c65c8 Flask-LDAP-0.1.4.tar.gz"
+sha512sums="74dfb65ec199656f5f8a33eaa6bd5c6540a384e8fb7aefea6c26a411a088cb99e897dae06d91f38f0c244072986a7d575a9e1f23a14026191d768471aa6e540c Flask-LDAP-0.1.4.tar.gz"