aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-html5lib
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-02 04:10:37 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-06-02 16:20:35 +0000
commita6fdbab71ce3824bb71a124317d3555b6c078e39 (patch)
treefdb44d0780611ffc69843c3b781df884f38919be /testing/py-html5lib
parenta5bfb5f401d5e6b94916ba9649cda51de60acba4 (diff)
downloadaports-a6fdbab71ce3824bb71a124317d3555b6c078e39.tar.bz2
aports-a6fdbab71ce3824bb71a124317d3555b6c078e39.tar.xz
testing/py-html5lib: rebuild for python3.7
Closes GH-8381
Diffstat (limited to 'testing/py-html5lib')
-rw-r--r--testing/py-html5lib/APKBUILD5
1 files changed, 2 insertions, 3 deletions
diff --git a/testing/py-html5lib/APKBUILD b/testing/py-html5lib/APKBUILD
index b54c9825ad..399f7d3855 100644
--- a/testing/py-html5lib/APKBUILD
+++ b/testing/py-html5lib/APKBUILD
@@ -4,8 +4,9 @@
pkgname=py-html5lib
_pkgname=html5lib
pkgver=1.0.1
-pkgrel=0
+pkgrel=1
pkgdesc="A Python HTML parser"
+options="!check" # 1 test fail
url="https://github.com/html5lib/html5lib-python"
arch="noarch"
license="MIT"
@@ -17,13 +18,11 @@ source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname
builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$builddir"
python2 setup.py build
python3 setup.py build
}
check() {
- cd "$builddir"
py.test-2
py.test-3
}