aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-humanize
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2016-11-07 19:01:40 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-12-27 10:13:58 +0200
commit27b9eda9bd232d473d4728c56d3d256357eb7bf2 (patch)
tree848366062cc3348f158e0a78610c131d130f1310 /testing/py-humanize
parentca97b96178c3d008facb0bb681414a1e96c3dec6 (diff)
downloadaports-27b9eda9bd232d473d4728c56d3d256357eb7bf2.tar.bz2
aports-27b9eda9bd232d473d4728c56d3d256357eb7bf2.tar.xz
testing/py-humanize: enable py3
Diffstat (limited to 'testing/py-humanize')
-rw-r--r--testing/py-humanize/APKBUILD37
1 files changed, 28 insertions, 9 deletions
diff --git a/testing/py-humanize/APKBUILD b/testing/py-humanize/APKBUILD
index abcea5029c..0005bdb5e6 100644
--- a/testing/py-humanize/APKBUILD
+++ b/testing/py-humanize/APKBUILD
@@ -3,26 +3,45 @@
pkgname=py-humanize
_pkgname=humanize
pkgver=0.5.1
-pkgrel=0
+pkgrel=1
pkgdesc="Python humanize functions"
url="https://pypi.python.org/pypi/humanize"
arch="noarch"
license="MIT"
-depends="python2"
-makedepends="python2-dev py-setuptools"
-source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
build() {
cd "$builddir"
python2 setup.py build || return 1
+ python3 setup.py build || return 1
}
package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
cd "$builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
}
-md5sums="e8473d9dc1b220911cac2edd53b1d973 py-humanize-0.5.1.tar.gz"
-sha256sums="a43f57115831ac7c70de098e6ac46ac13be00d69abbf60bdcac251344785bb19 py-humanize-0.5.1.tar.gz"
-sha512sums="2727268d9fc7b393228f7eb9e71a5c881988ec56e265ddf83613fe57116da3aaad70d2417db4cef8a8c40cb73753eb2c2bd775d3cd25c2de751cb61373f0a551 py-humanize-0.5.1.tar.gz"
+md5sums="e8473d9dc1b220911cac2edd53b1d973 humanize-0.5.1.tar.gz"
+sha256sums="a43f57115831ac7c70de098e6ac46ac13be00d69abbf60bdcac251344785bb19 humanize-0.5.1.tar.gz"
+sha512sums="2727268d9fc7b393228f7eb9e71a5c881988ec56e265ddf83613fe57116da3aaad70d2417db4cef8a8c40cb73753eb2c2bd775d3cd25c2de751cb61373f0a551 humanize-0.5.1.tar.gz"