aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-inotify
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2016-11-08 21:35:33 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-12-27 09:50:21 +0200
commitb8e4e69ce6e1aa0515acfaf00aedef3f0bc847cb (patch)
tree567d39a1eded30216de75096792052d58c0941c7 /testing/py-inotify
parent68d8c189bf578b5caf4283bf2827852aeaa974d4 (diff)
downloadaports-b8e4e69ce6e1aa0515acfaf00aedef3f0bc847cb.tar.bz2
aports-b8e4e69ce6e1aa0515acfaf00aedef3f0bc847cb.tar.xz
testing/py-inotify: upgrade to 0.9.6 and enable py3
Diffstat (limited to 'testing/py-inotify')
-rw-r--r--testing/py-inotify/APKBUILD52
1 files changed, 29 insertions, 23 deletions
diff --git a/testing/py-inotify/APKBUILD b/testing/py-inotify/APKBUILD
index 167dd9b478..e17b25b15e 100644
--- a/testing/py-inotify/APKBUILD
+++ b/testing/py-inotify/APKBUILD
@@ -1,40 +1,46 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py-inotify
_pkgname=pyinotify
-pkgver=0.9.4
+pkgver=0.9.6
pkgrel=0
pkgdesc="Linux filesystem events monitoring"
url="http://pypi.python.org/pypi/pyinotify"
arch="noarch"
license="MIT"
-depends="python2"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
python2 setup.py build || return 1
+ python3 setup.py build || return 1
}
package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
}
-md5sums="701c91854d241514ede7ffe72086566d pyinotify-0.9.4.tar.gz"
-sha256sums="a09767e4e0610e2e1e9f9dc89483b0ee4a53764e700f5866a570bec51d003fec pyinotify-0.9.4.tar.gz"
-sha512sums="cdaf9f239a43e3889cdca0ebe1e3559bf6411e4cd829120cc2199cb91122bfe4af62f61a9bf297de28036716f974abd4d7bbeb210e22e96245781fbad08a2b75 pyinotify-0.9.4.tar.gz"
+md5sums="8e580fa1ff3971f94a6f81672b76c406 pyinotify-0.9.6.tar.gz"
+sha256sums="9c998a5d7606ca835065cdabc013ae6c66eb9ea76a00a1e3bc6e0cfe2b4f71f4 pyinotify-0.9.6.tar.gz"
+sha512sums="b52de43293b06b32236e90b7c33fac061f3095cd7d4aecec89a099d56020db1a85440ab9dcc8b521238c001fc49a1f37d1b16d621bc1acab4d7273aebcaadbc5 pyinotify-0.9.6.tar.gz"