aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-itypes
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2017-12-24 22:33:33 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-12-24 22:33:53 +0000
commit49768085ada7f6ad50489a836192cae639da12b5 (patch)
treed363a20e59e2a427cfeb4f40e501f4a607883a18 /testing/py-itypes
parent5f220d12ebabb440dee30ea3787d78835521362d (diff)
downloadaports-49768085ada7f6ad50489a836192cae639da12b5.tar.bz2
aports-49768085ada7f6ad50489a836192cae639da12b5.tar.xz
testing/py-itypes: fix build
Diffstat (limited to 'testing/py-itypes')
-rw-r--r--testing/py-itypes/APKBUILD8
-rw-r--r--testing/py-itypes/disable-flake8.patch30
2 files changed, 35 insertions, 3 deletions
diff --git a/testing/py-itypes/APKBUILD b/testing/py-itypes/APKBUILD
index 880daaa64c..94e8cb0955 100644
--- a/testing/py-itypes/APKBUILD
+++ b/testing/py-itypes/APKBUILD
@@ -9,11 +9,12 @@ url="https://github.com/tomchristie/itypes"
arch="noarch"
license="Unknown"
depends=""
-makedepends="python2-dev python3-dev py3-setuptools"
+makedepends="python2-dev python3-dev py2-setuptools"
checkdepends="py2-flake8 py3-flake8 py2-pytest py3-pytest py-enum34
py2-pycodestyle py3-pycodestyle py2-pyflakes py3-pyflakes"
subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-source="$pkgname-$pkgver.tar.gz::https://github.com/tomchristie/itypes/archive/$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/tomchristie/itypes/archive/$pkgver.tar.gz
+ disable-flake8.patch"
builddir="$srcdir"/$_pkgreal-$pkgver
build() {
@@ -54,4 +55,5 @@ _py() {
$python setup.py --quiet install --prefix=/usr --root="$subpkgdir"
}
-sha512sums="2f6dd5d655f1031059df8dcfd0a2f76875796a800144e887fb66cb5585949097edb6b9f5e973de2280f43cfeb25ab99d3ca428372fe239c8cd70f385304bcdd7 py-itypes-1.1.0.tar.gz"
+sha512sums="2f6dd5d655f1031059df8dcfd0a2f76875796a800144e887fb66cb5585949097edb6b9f5e973de2280f43cfeb25ab99d3ca428372fe239c8cd70f385304bcdd7 py-itypes-1.1.0.tar.gz
+71421f34cf7c4303a2bb8dbbe48d7098f183ce41ed7bf454efa199d031a88c54c84a93eb84d0fa14b8231086709d2949eec7b6bbdb55af7aae4d62a734056d69 disable-flake8.patch"
diff --git a/testing/py-itypes/disable-flake8.patch b/testing/py-itypes/disable-flake8.patch
new file mode 100644
index 0000000000..91ee70a28b
--- /dev/null
+++ b/testing/py-itypes/disable-flake8.patch
@@ -0,0 +1,30 @@
+--- itypes-1.1.0.orig/runtests
++++ itypes-1.1.0/runtests
+@@ -6,7 +6,6 @@
+
+
+ PYTEST_ARGS = ['tests.py', '--tb=short']
+-FLAKE8_ARGS = ['itypes.py', 'tests.py', '--ignore=E501']
+ COVERAGE_OPTIONS = {
+ 'include': ['itypes.py', 'tests.py'],
+ }
+@@ -25,13 +24,6 @@
+ sys.exit(ret)
+
+
+-def flake8_main(args):
+- print('Running flake8 code linting')
+- ret = subprocess.call(['flake8'] + args)
+- print('flake8 failed' if ret else 'flake8 passed')
+- return ret
+-
+-
+ def fail_if_lacking_coverage(cov):
+ precent_covered = cov.report(
+ file=NullFile(), **COVERAGE_OPTIONS
+@@ -82,5 +74,4 @@
+ # cov.start()
+ exit_on_failure(pytest.main(pytest_args))
+ # cov.stop()
+- exit_on_failure(flake8_main(FLAKE8_ARGS))
+ # fail_if_lacking_coverage(cov)