aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-kombu
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2017-08-15 02:43:51 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-08-15 02:43:51 +0000
commit1b1bfc2055714e2e3b82917f3427446570a732e0 (patch)
tree8de6890b51f7e1535403ba5926e830a47a446478 /testing/py-kombu
parent48995315a2914313b3bb1c65c823d4c99cbc7397 (diff)
downloadaports-1b1bfc2055714e2e3b82917f3427446570a732e0.tar.bz2
aports-1b1bfc2055714e2e3b82917f3427446570a732e0.tar.xz
testing/py-kombu: new aport
Diffstat (limited to 'testing/py-kombu')
-rw-r--r--testing/py-kombu/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/testing/py-kombu/APKBUILD b/testing/py-kombu/APKBUILD
new file mode 100644
index 0000000000..2b623a63c9
--- /dev/null
+++ b/testing/py-kombu/APKBUILD
@@ -0,0 +1,46 @@
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=py-kombu
+pkgver=4.1.0
+pkgrel=0
+pkgdesc="a message queue abstraction layer"
+url="https://pypi.python.org/pypi/kombu/"
+arch="noarch"
+license="BSD"
+depends=""
+makedepends="python2-dev python3-dev py-setuptools"
+install=""
+subpackages="py2-kombu:py2 py3-kombu:py3"
+source="https://files.pythonhosted.org/packages/source/k/kombu/kombu-$pkgver.tar.gz"
+builddir="$srcdir/kombu-$pkgver"
+
+build() {
+ cd "$_builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc ${python#python}"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+py2() {
+ cd "$builddir"
+ _py python2
+}
+
+py3() {
+ cd "$builddir"
+ _py python3
+}
+
+sha512sums="fc104a3f974fabf090cc257b1a7623af6048f4630c6c2a9bb693fe69d77b6cdab36135a290a41056c1f854f61cce8fc2aa6b7880e9273581bfdfa162b5724861 kombu-4.1.0.tar.gz"