aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-librtmp
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-04-19 14:10:01 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-04-19 14:10:01 +0000
commit51ca2418aab99284e66f9ab15f5fd96657197fd4 (patch)
tree81e71c54c05febf069d2a2c6b582b6a2b7871201 /testing/py-librtmp
parenta3a63b179ba832793391b2bb27bd9223c1ed555d (diff)
downloadaports-51ca2418aab99284e66f9ab15f5fd96657197fd4.tar.bz2
aports-51ca2418aab99284e66f9ab15f5fd96657197fd4.tar.xz
testing/py-librtmp: new aport
Diffstat (limited to 'testing/py-librtmp')
-rw-r--r--testing/py-librtmp/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/py-librtmp/APKBUILD b/testing/py-librtmp/APKBUILD
new file mode 100644
index 0000000000..bfd9b86282
--- /dev/null
+++ b/testing/py-librtmp/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py-librtmp
+_pkgname=python-librtmp
+pkgver=0.3.0
+pkgrel=0
+pkgdesc="Python bindings for librtmp, built with cffi"
+url="https://pypi.python.org/pypi/python-librtmp"
+arch="all"
+license="BSD"
+depends="py-setuptools rtmpdump-dev py-cffi py-singledispatch"
+depends_dev=""
+makedepends="$depends_dev python-dev"
+install=""
+subpackages=""
+source="https://pypi.python.org/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir"/$_pkgname-$pkgver
+build() {
+ cd "$builddir"
+ python setup.py build || return 1
+ python setup.py test || return 1
+}
+
+package() {
+ cd "$builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="f7afe8d463214072281998fa84553927 python-librtmp-0.3.0.tar.gz"
+sha256sums="4a41ada646270baa5b388f17481d08679d23b2947835901d0db7602c59ec772b python-librtmp-0.3.0.tar.gz"
+sha512sums="1fa529f5c68341f225849061cbcf6883f80e48a492fae8319336ea1e17c22070d5bd204f768b2561b0ef8dfdf29b38789673fab3d3386290143eb94d2b51b8fe python-librtmp-0.3.0.tar.gz"