aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-luhn/APKBUILD
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-30 20:01:38 +0300
committerprspkt <prspkt@protonmail.com>2019-06-30 20:01:43 +0300
commite57e0a7b024fa882a13b6c7bd0dcf59f1414ac90 (patch)
treee40307155b94aad8bf827d3deb12debd0a246607 /testing/py-luhn/APKBUILD
parentc35300466ec54df10082ba436be03c0841cec8fb (diff)
downloadaports-e57e0a7b024fa882a13b6c7bd0dcf59f1414ac90.tar.bz2
aports-e57e0a7b024fa882a13b6c7bd0dcf59f1414ac90.tar.xz
testing/py-luhn: drop python2
Diffstat (limited to 'testing/py-luhn/APKBUILD')
-rw-r--r--testing/py-luhn/APKBUILD46
1 files changed, 0 insertions, 46 deletions
diff --git a/testing/py-luhn/APKBUILD b/testing/py-luhn/APKBUILD
deleted file mode 100644
index f9038a1560..0000000000
--- a/testing/py-luhn/APKBUILD
+++ /dev/null
@@ -1,46 +0,0 @@
-# Maintainer:
-pkgname=py-luhn
-pkgver=0.2.0
-pkgrel=1
-pkgdesc="generate and validate luhn check digits"
-url="https://pypi.python.org/pypi/luhn/"
-arch="noarch"
-license="BSD"
-depends="py-amqp"
-makedepends="python2-dev python3-dev py-setuptools"
-install=""
-subpackages="py2-luhn:py2 py3-luhn:py3"
-source="https://files.pythonhosted.org/packages/source/l/luhn/luhn-$pkgver.tar.gz"
-builddir="$srcdir/luhn-$pkgver"
-
-build() {
- cd "$_builddir"
- python2 setup.py build
- python3 setup.py build
-}
-
-package() {
- mkdir -p "$pkgdir"
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc ${python#python}"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-py2() {
- cd "$builddir"
- _py python2
-}
-
-py3() {
- cd "$builddir"
- _py python3
-}
-
-sha512sums="81c5be3ae22069f409098ad3c333e90514cfd1dd351974cabfd03981790e408bd65129f46b1a05dc9411d566c4a9ceb62b0942a276a1bb561c3b3282685b46f7 luhn-0.2.0.tar.gz"