aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-lxc-python2
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-02-21 15:42:40 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-02-21 15:42:50 +0000
commit438f15f5ad561c6b6f60223913279a3cd0bf5aa9 (patch)
tree0f017535bc05f7339c14999784ed2da1613644d0 /testing/py-lxc-python2
parentf18fdcb41ea0524542edea6c3053197394403919 (diff)
downloadaports-438f15f5ad561c6b6f60223913279a3cd0bf5aa9.tar.bz2
aports-438f15f5ad561c6b6f60223913279a3cd0bf5aa9.tar.xz
testing/py-lxc-python2: new aport
Diffstat (limited to 'testing/py-lxc-python2')
-rw-r--r--testing/py-lxc-python2/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/py-lxc-python2/APKBUILD b/testing/py-lxc-python2/APKBUILD
new file mode 100644
index 0000000000..4df7438675
--- /dev/null
+++ b/testing/py-lxc-python2/APKBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+_pkgname=lxc-python2
+pkgname=py-${_pkgname}
+pkgver=0.1
+pkgrel=0
+pkgdesc="Python2 bindings for LXC"
+url="https://pypi.python.org/pypi/lxc-python2"
+arch="all"
+license="LGPLv2+"
+depends=""
+makedepends="lxc-dev python-dev py-setuptools"
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+sha512sums="e2374373dbf0567209f028df6c8dcf66b1f06be89934824c9663104e4fed9341f2b68d89011624f87de0e4e2702affaf1f7b17987bb179d1d945c2e04f8aa1bc lxc-python2-0.1.zip"