aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-netlib/APKBUILD
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2018-02-04 10:14:50 +0000
committerTimo Teräs <timo.teras@iki.fi>2018-02-05 18:57:18 +0000
commitdd396e47deff525e9448be136f1ef23eb8540105 (patch)
tree855047382ff918d37bc5289cc742e62c8173e999 /testing/py-netlib/APKBUILD
parentd6e8e9b1dd25727664a0b73481dc6daccba80463 (diff)
downloadaports-dd396e47deff525e9448be136f1ef23eb8540105.tar.bz2
aports-dd396e47deff525e9448be136f1ef23eb8540105.tar.xz
testing/py-netlib: upgrade to 0.16
Diffstat (limited to 'testing/py-netlib/APKBUILD')
-rw-r--r--testing/py-netlib/APKBUILD27
1 files changed, 8 insertions, 19 deletions
diff --git a/testing/py-netlib/APKBUILD b/testing/py-netlib/APKBUILD
index edf4e3746f..4b2723a9c3 100644
--- a/testing/py-netlib/APKBUILD
+++ b/testing/py-netlib/APKBUILD
@@ -2,40 +2,29 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py-netlib
_pkgname=netlib
-pkgver=0.15
+pkgver=0.16
pkgrel=0
pkgdesc="A Collection of network utility classes"
url="https://github.com/mitmproxy/netlib"
arch="noarch"
license="MIT"
+options="!check"
depends="python2 py-openssl py-asn1"
depends_dev=""
makedepends="python2-dev py-setuptools"
install=""
subpackages=""
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$_builddir"
- python2 setup.py build || return 1
+ cd "$builddir"
+ python2 setup.py build
}
package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="b4f8c430dd9cae6c9b981b72c9954ffc netlib-0.15.tar.gz"
-sha256sums="5f5c02724a32f4d44401a9dccaf7d3bdf077a352d11dc5131bb61fb24299afa5 netlib-0.15.tar.gz"
-sha512sums="432ce150e4e8a4f5161a0bac528f039256a82d7814e195909beba60cbf045dbe015c978d86bf054f396b9ad11c674ca6019b54c4a796b37393b4a3433a2ada08 netlib-0.15.tar.gz"
+sha512sums="7beb7fa8bde6fb994d15af770d8e0e006d1bdeb499f7f0fbff1466ae99212904ff065f7b2257d6576e7c257c52010baf4dea38fc43ac3fd9832e3e5be41c969f netlib-0.16.tar.gz"