aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-olefile
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-05-24 08:50:15 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-05-24 08:50:15 +0000
commit67398246e9cb36f9645b2486ccebbd3b65eca729 (patch)
tree97df186e1f38251b2c2ffb6aed41f4dace955dfa /testing/py-olefile
parent86541551cfe474256f698e8749d0c8fc164577cb (diff)
downloadaports-67398246e9cb36f9645b2486ccebbd3b65eca729.tar.bz2
aports-67398246e9cb36f9645b2486ccebbd3b65eca729.tar.xz
testing/py-olefile: new aport
Diffstat (limited to 'testing/py-olefile')
-rw-r--r--testing/py-olefile/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/py-olefile/APKBUILD b/testing/py-olefile/APKBUILD
new file mode 100644
index 0000000000..a7349e5c7d
--- /dev/null
+++ b/testing/py-olefile/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py-olefile
+pkgver=0.43
+pkgrel=0
+pkgdesc="A Python module to read/write MS OLE2 files"
+url="http://www.decalage.info/olefile"
+arch="noarch"
+license="custom"
+depends=""
+depends_dev=""
+makedepends="$depends_dev python-dev py-setuptools"
+install=""
+subpackages="$pkgname-doc"
+source="https://bitbucket.org/decalage/olefileio_pl/downloads/${pkgname/py-/}-$pkgver.tar.gz"
+
+builddir="$srcdir"/${pkgname/py-/}-$pkgver
+build() {
+ cd "$builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ install -Dm644 olefile/LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+md5sums="f570df81ebfab51aaa538af39fef6fd3 olefile-0.43.tar.gz"
+sha256sums="57102bf3f19c5fa099c0c7128190fe4bb28cd2760aa08f4b5b7dccf28718b876 olefile-0.43.tar.gz"
+sha512sums="5a2fbe69bbe13f2633b4d6c8861531f4ac0b41379fea889a6e74a1f0f78960e2b9db10516fae5f3d2a59f2dac6a6befcd78c11a9fc45212009a3097cdc5f61ea olefile-0.43.tar.gz"