aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-pep8-naming
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-20 15:09:26 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-20 15:09:26 -0300
commit7808ce4cb361fa6788c7359f19551ec01128eeee (patch)
tree93fa0e4fd94e07669ab320b74d81e580971ddeb5 /testing/py-pep8-naming
parent6468648c4e226d39d7b594747b562c39695ed0e0 (diff)
downloadaports-7808ce4cb361fa6788c7359f19551ec01128eeee.tar.bz2
aports-7808ce4cb361fa6788c7359f19551ec01128eeee.tar.xz
testing/py3-pep8-naming: rename from py-pep8-naming
Diffstat (limited to 'testing/py-pep8-naming')
-rw-r--r--testing/py-pep8-naming/APKBUILD55
1 files changed, 0 insertions, 55 deletions
diff --git a/testing/py-pep8-naming/APKBUILD b/testing/py-pep8-naming/APKBUILD
deleted file mode 100644
index f819e56e9a..0000000000
--- a/testing/py-pep8-naming/APKBUILD
+++ /dev/null
@@ -1,55 +0,0 @@
-# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-pep8-naming
-_pkgname=pep8-naming
-pkgver=0.8.2
-pkgrel=0
-pkgdesc="Check PEP-8 naming conventions plugin for flake8"
-url="https://github.com/flintwork/pep8-naming"
-arch="noarch"
-license="MIT"
-depends="python2 python3 py-flake8"
-makedepends="python2-dev python3-dev py-setuptools"
-checkdepends="py-six py-tox py-virtualenv"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
-
-build() {
- cd "$builddir"
- python2 setup.py build
- python3 setup.py build
-}
-
-check() {
- cd "$builddir"
- python2 setup.py test
- python3 setup.py test
-}
-
-package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-sha512sums="08b13a58c9ab4f12e3825908e741f68ea6542eab4a9e1c041952f611f3caa033a3c4e581ee2fba3d2db889857ff05713dcc19bd497d66d4e8d496403fd284207 pep8-naming-0.8.2.tar.gz"