aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-pluggy
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2017-05-19 17:51:54 +0000
committerShiz <hi@shiz.me>2017-06-03 19:43:00 +0200
commitbe4e3a69ca79f89fed6a6061a0e09611ca7913ac (patch)
treed28e9043b8b05b540cf435bb367c75f1fa6749c7 /testing/py-pluggy
parenta8863590bd5251ca7e78bee4ee6cdb9125a08bb2 (diff)
downloadaports-be4e3a69ca79f89fed6a6061a0e09611ca7913ac.tar.bz2
aports-be4e3a69ca79f89fed6a6061a0e09611ca7913ac.tar.xz
testing/py-pluggy: new aport
Diffstat (limited to 'testing/py-pluggy')
-rw-r--r--testing/py-pluggy/APKBUILD56
1 files changed, 56 insertions, 0 deletions
diff --git a/testing/py-pluggy/APKBUILD b/testing/py-pluggy/APKBUILD
new file mode 100644
index 0000000000..62ab9a3b54
--- /dev/null
+++ b/testing/py-pluggy/APKBUILD
@@ -0,0 +1,56 @@
+# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
+# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
+pkgname=py-pluggy
+_pkgname=${pkgname#py-*}
+pkgver=0.4.0
+pkgrel=0
+pkgdesc="Plugin management and hook calling for Python"
+url="https://pluggy.readthedocs.io/en/latest/"
+arch="noarch"
+license="MIT"
+makedepends="python2-dev python3-dev py-setuptools"
+#checkdepends="flake8 pytest py-tox"
+options="!check" # temp disable as requires tox module
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="$pkgname-$pkgver.tar.gz::https://github.com/pytest-dev/$_pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+check() {
+ cd "$builddir"
+ sed -i 's|envlist.*|envlist=check,py{27,36}-pytest{30}|' tox.ini
+ tox
+}
+
+
+
+
+sha512sums="dea3cdc045d295adf99ef1932ffad542bf57d5ecd91f5b48815f0a65e5f7ffd56e8e727436a20c83e5c261995092a0c561c81a5b20566f97768a24be1dd52eb1 py-pluggy-0.4.0.tar.gz"