aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-pyautogui
diff options
context:
space:
mode:
authorIvan Tham <pickfire@riseup.net>2017-04-28 01:19:56 +0800
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-06-02 08:33:52 +0000
commit3d70719b32263d20639f9993f77d5d9ef69590af (patch)
tree6b678f2ffa229559d9622c439a8a5d405563ccbf /testing/py-pyautogui
parent62be9f37fa1fef31438835410f9e8153b1a5c87a (diff)
downloadaports-3d70719b32263d20639f9993f77d5d9ef69590af.tar.bz2
aports-3d70719b32263d20639f9993f77d5d9ef69590af.tar.xz
testing/py-pyautogui: new aport
http://pyautogui.readthedocs.io/ A cross-platform Python module for GUI automation for human beings
Diffstat (limited to 'testing/py-pyautogui')
-rw-r--r--testing/py-pyautogui/APKBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/testing/py-pyautogui/APKBUILD b/testing/py-pyautogui/APKBUILD
new file mode 100644
index 0000000000..f8b9b131e3
--- /dev/null
+++ b/testing/py-pyautogui/APKBUILD
@@ -0,0 +1,54 @@
+# Contributor: Ivan Tham <pickfire@riseup.net>
+# Maintainer: Ivan Tham <pickfire@riseup.net>
+pkgname=py-pyautogui
+_pkgname=PyAutoGUI
+pkgver=0.9.35
+pkgrel=0
+pkgdesc="A cross-platform Python module for GUI automation for human beings"
+url="http://pyautogui.readthedocs.io/"
+arch="noarch"
+license="BSD"
+depends="py-xlib py-pillow"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py3-$_pkgname:_py3 py2-$_pkgname:_py2"
+source="https://github.com/asweigart/pyautogui/archive/master.zip" # TODO: find a better source
+builddir="$srcdir/pyautogui-master"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python2 setup.py check
+ python3 setup.py check
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="7369e846f9a2d8f6af4752e424ed867f857fb7a98f946311d45003fda93b69ec73b3866e16a001479b9dbd19ec1634959ac083e8199cda9fb60a650260dcde6d master.zip"