aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-pyphen
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2013-08-24 13:26:21 -0500
committerWilliam Pitcock <nenolod@dereferenced.org>2013-08-24 13:26:21 -0500
commitd346701104b229534be21ebba771b85bce958c8f (patch)
tree83fb08c6d6f83e927b1d3c4b25e8b5334cd8ff0e /testing/py-pyphen
parent0a53ce7bb5f272608b192faee6809cacffbf0acf (diff)
downloadaports-d346701104b229534be21ebba771b85bce958c8f.tar.bz2
aports-d346701104b229534be21ebba771b85bce958c8f.tar.xz
testing/py-pyphen: new aport
Diffstat (limited to 'testing/py-pyphen')
-rw-r--r--testing/py-pyphen/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/py-pyphen/APKBUILD b/testing/py-pyphen/APKBUILD
new file mode 100644
index 0000000000..c838f17ca4
--- /dev/null
+++ b/testing/py-pyphen/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=py-pyphen
+pkgver=0.8
+pkgrel=0
+pkgdesc="python-based dictionary hyphenator library"
+url="http://www.pyphen.org/"
+arch="noarch"
+license="GPL MPL LGPL"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/P/Pyphen/Pyphen-$pkgver.tar.gz"
+
+_builddir="$srcdir"/Pyphen-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="eeb03180bbb6f65f98a16118341ee454 Pyphen-0.8.tar.gz"
+sha256sums="378169ce89b8d3b6a0b95bbfdedc9da8c428d6b7c98ff6498ff41c390702a21a Pyphen-0.8.tar.gz"
+sha512sums="230ae11fa3aabba52c923a562284cbc9051c42aa8bc6336bf7e66a47db8974adb3fe136f605bac4cb8c5dee20e68181e6fb3b0c5726a35ab85d11ac5e30c537a Pyphen-0.8.tar.gz"