aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-sortedcontainers
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-04-23 15:03:37 +0000
committerAndy Postnikov <apostnikov@gmail.com>2018-04-24 00:46:58 +0300
commit9d5425646f2f0298322acb53f5743335ecec7e63 (patch)
treec7afc57d4f1597af457e12898bc7c17609afc793 /testing/py-sortedcontainers
parentf7b73dba862f6a4907827cfc8b613e738dd2a2e6 (diff)
downloadaports-9d5425646f2f0298322acb53f5743335ecec7e63.tar.bz2
aports-9d5425646f2f0298322acb53f5743335ecec7e63.tar.xz
testing/py-sortedcontainers: clarify license, improve abuild
Diffstat (limited to 'testing/py-sortedcontainers')
-rw-r--r--testing/py-sortedcontainers/APKBUILD38
1 files changed, 19 insertions, 19 deletions
diff --git a/testing/py-sortedcontainers/APKBUILD b/testing/py-sortedcontainers/APKBUILD
index d014b95aa8..dcb01bb9c9 100644
--- a/testing/py-sortedcontainers/APKBUILD
+++ b/testing/py-sortedcontainers/APKBUILD
@@ -4,20 +4,20 @@ pkgname=py-sortedcontainers
_pkgname=sortedcontainers
pkgver=1.5.10
pkgrel=0
-pkgdesc="Python Sorted Container Types: SortedList, SortedDict, and SortedSet"
-url="http://www.grantjenks.com/docs/sortedcontainers/"
+pkgdesc="Python library for sorting collections and containers"
+url="http://www.grantjenks.com/docs/sortedcontainers"
arch="noarch"
-license="Apache"
-makedepends="python2-dev py-setuptools python3-dev"
+license="Apache-2.0"
+makedepends="py-setuptools python2-dev python3-dev"
checkdepends="py-nose"
-subpackages="py3-${pkgname#py-}:_py3 py2-${pkgname#py-}:_py2"
-source="$_pkgname-$pkgver.tar.gz::https://github.com/grantjenks/sorted_containers/archive/v$pkgver.tar.gz"
-builddir="$srcdir/sorted_containers-$pkgver"
+subpackages="py2-$_pkgname:_py2 py3-$_pkgname:_py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
build() {
cd "$builddir"
- python2 setup.py build || return 1
- python3 setup.py build || return 1
+ python2 setup.py build
+ python3 setup.py build
}
check() {
@@ -30,6 +30,15 @@ package() {
mkdir -p "$pkgdir"
}
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
_py() {
local python="$1"
pkgdesc="$pkgdesc (for $python)"
@@ -40,13 +49,4 @@ _py() {
$python setup.py install --prefix=/usr --root="$subpkgdir"
}
-_py2() {
- replaces="$pkgname"
- _py python2
-}
-
-_py3() {
- _py python3
-}
-
-sha512sums="22ec92d9d7dc44159f47be9b028cc468637cae68d4702fff87e8531a155d56bb031b32c77efcc6f839ead19d27471cb80660fe990b3d424ed1fe58178ee803b8 sortedcontainers-1.5.10.tar.gz"
+sha512sums="4dc61a965b1f5e99fef7639805785465ff02406034ceb0b029848900aab6c5138cf94facf9b40197ba836e31f57ca26cff80c52294337896b91571c27da74485 sortedcontainers-1.5.10.tar.gz"