aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-sphinx-theme-cloud
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-10 11:12:01 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-02 09:02:53 +0000
commit997d5ba09659585560335982216730e68030d09b (patch)
tree240688afd1379dabfecbf13299e503595ecaf3f0 /testing/py-sphinx-theme-cloud
parentc570fd348e22206e368669c6c99622ffa660ad54 (diff)
downloadaports-997d5ba09659585560335982216730e68030d09b.tar.bz2
aports-997d5ba09659585560335982216730e68030d09b.tar.xz
testing/py-sphinx-theme-cloud: new aport
The Cloud Sphinx theme https://bitbucket.org/ecollins/cloud_sptheme
Diffstat (limited to 'testing/py-sphinx-theme-cloud')
-rw-r--r--testing/py-sphinx-theme-cloud/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-sphinx-theme-cloud/APKBUILD b/testing/py-sphinx-theme-cloud/APKBUILD
new file mode 100644
index 0000000000..5b1a67d837
--- /dev/null
+++ b/testing/py-sphinx-theme-cloud/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-sphinx-theme-cloud
+_pkgname=cloud_sptheme
+pkgver=1.5
+pkgrel=0
+pkgdesc="The Cloud Sphinx theme"
+url="https://bitbucket.org/ecollins/cloud_sptheme"
+arch="noarch"
+license="BSD"
+depends="python py-sphinx"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="d5a5f9d4996083ed661981f6d244eb93 cloud_sptheme-1.5.tar.gz"
+sha256sums="54967ff0a0d85fa592582c1ebd332d1aa709de2e4c5a3e360feea03803cb4293 cloud_sptheme-1.5.tar.gz"
+sha512sums="8c28c86f659447447eed64a90b872c04f94f1efcd6615f15ef8836c39674233fce34df8fe226f49f2142ce43c0a3daca2c1666c860e98ce5d66ac269c398d2c2 cloud_sptheme-1.5.tar.gz"