aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-sphinxcontrib-embedly
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2014-08-21 18:05:56 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2014-08-23 10:28:59 +0000
commit501cf28a2bbbc69a2574994c64570f53951ea51c (patch)
treed0a5f37ce917139ee357a227ac2d08a12b277cc8 /testing/py-sphinxcontrib-embedly
parent56cc2787bbe0bf71c4d01a5bbfe803ff8507ee96 (diff)
downloadaports-501cf28a2bbbc69a2574994c64570f53951ea51c.tar.bz2
aports-501cf28a2bbbc69a2574994c64570f53951ea51c.tar.xz
testing/py-sphinxcontrib-embedly: new aport
Sphinx "embedly" extension https://pypi.python.org/pypi/sphinxcontrib-embedly
Diffstat (limited to 'testing/py-sphinxcontrib-embedly')
-rw-r--r--testing/py-sphinxcontrib-embedly/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-sphinxcontrib-embedly/APKBUILD b/testing/py-sphinxcontrib-embedly/APKBUILD
new file mode 100644
index 0000000000..cc4debed0a
--- /dev/null
+++ b/testing/py-sphinxcontrib-embedly/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-sphinxcontrib-embedly
+_pkgname=sphinxcontrib-embedly
+pkgver=0.2
+pkgrel=0
+pkgdesc="Sphinx embedly extension"
+url="https://pypi.python.org/pypi/sphinxcontrib-embedly"
+arch="noarch"
+license="BSD"
+depends="python py-sphinx py-embedly"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="efbe244a16f268ceec11390a0801cf0e sphinxcontrib-embedly-0.2.tar.gz"
+sha256sums="1781b9e8108334acfd9c13e3cc28228510810985ae351e16995a959fc86c9013 sphinxcontrib-embedly-0.2.tar.gz"
+sha512sums="1b06c2b30582ae039184003a2328140250350ee41dfa916f5c3060eede614a843289e926cce3246706ed3b95a9a2e34b340b7efb7cc8b30abb910ce3efa14827 sphinxcontrib-embedly-0.2.tar.gz"