aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-unicorn-hat
diff options
context:
space:
mode:
authorScrumpyJack <scrumpyjack@st.ilet.to>2016-04-06 08:12:01 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-04-15 06:49:36 +0000
commitc09726e8ef65b10abe2e81d3d19fb2f973bb0de4 (patch)
treec08e7e20b8e54765506be4ccbeb4a02ef1a96f32 /testing/py-unicorn-hat
parentbf8fe206f1bfbfa9466f12466d0a7647340542a7 (diff)
downloadaports-c09726e8ef65b10abe2e81d3d19fb2f973bb0de4.tar.bz2
aports-c09726e8ef65b10abe2e81d3d19fb2f973bb0de4.tar.xz
testing/py-unicorn-hat: new aport
Python wrapper for driving ws2812 pixels from the Raspberry Pi http://shop.pimoroni.com/products/unicorn-hat
Diffstat (limited to 'testing/py-unicorn-hat')
-rw-r--r--testing/py-unicorn-hat/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-unicorn-hat/APKBUILD b/testing/py-unicorn-hat/APKBUILD
new file mode 100644
index 0000000000..0c6fdad269
--- /dev/null
+++ b/testing/py-unicorn-hat/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
+# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
+pkgname=py-unicorni-hat
+_pkgname=unicorn-hat-unicornhat
+pkgver=2.1.0
+pkgrel=0
+pkgdesc="Python wrapper for driving ws2812 pixels from the Raspberry Pi"
+url="http://shop.pimoroni.com/products/unicorn-hat"
+arch="armhf"
+license="GPL2"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/pimoroni/unicorn-hat/archive/unicornhat-${pkgver}.tar.gz"
+_builddir=${srcdir}/${_pkgname}-${pkgver}
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir/python/UnicornHat"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir/python/UnicornHat"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ install -D -m0644 $_builddir/LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.txt
+}
+md5sums="e1731748d03372294edf5dedac670061 py-unicorni-hat-2.1.0.tar.gz"
+sha256sums="d9337d62b47cb0033cc95f4b90a2d5292429f756b30f34a29615db4dab6773b9 py-unicorni-hat-2.1.0.tar.gz"
+sha512sums="16a21f42a13222fa0742b2d60bcef85621519108e773840d8a73c17f3b38f38c18bd2b7038acd0b7338c69726b1a3f4da6524e37f5e7d46ce1450cd68af8e639 py-unicorni-hat-2.1.0.tar.gz"