aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-update-checker
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2014-05-30 17:14:47 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2014-07-07 18:12:31 +0000
commit79013251e73265dd9ee347a6192c518d68de187b (patch)
treea580e289ba91652b06dc0aaabeb70a4c2bdf3b19 /testing/py-update-checker
parentf8ebd17341088197a57e68316861328657f3b560 (diff)
downloadaports-79013251e73265dd9ee347a6192c518d68de187b.tar.bz2
aports-79013251e73265dd9ee347a6192c518d68de187b.tar.xz
testing/py-update-checker: new aport
A python module that will check for package updates https://github.com/bboe/update_checker
Diffstat (limited to 'testing/py-update-checker')
-rw-r--r--testing/py-update-checker/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-update-checker/APKBUILD b/testing/py-update-checker/APKBUILD
new file mode 100644
index 0000000000..fef17d5c8d
--- /dev/null
+++ b/testing/py-update-checker/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-update-checker
+_pkgname=update_checker
+pkgver=0.2
+pkgrel=0
+pkgdesc="A python module that will check for package updates"
+url="https://github.com/bboe/update_checker"
+arch="noarch"
+license="BSD"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="d2c30bdbbc260f7b138d74cdde80c4c8 update_checker-0.2.tar.gz"
+sha256sums="8eb1c0ca83622e248c4a81269103c41d787d3b9cc8f517e08b28ab9c38d1864b update_checker-0.2.tar.gz"
+sha512sums="3392205dab4232270260e513258a75afc54764d8f11e02376650bb6d4d416cb905b07f7c2df533b8ff473ea368d8a1c11da3c85556a4650c327bdf163ebd3b82 update_checker-0.2.tar.gz"