aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-xmpppy
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2011-01-09 22:32:33 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-01-10 12:40:18 +0000
commit9fbb196d08606d750353a6a3d84d48a44b71d4ee (patch)
treef67b48a113f722295fabee4fe340be3b91d601ab /testing/py-xmpppy
parent245c32ccdb99bf4756f9eb2834e5e5eb7a845331 (diff)
downloadaports-9fbb196d08606d750353a6a3d84d48a44b71d4ee.tar.bz2
aports-9fbb196d08606d750353a6a3d84d48a44b71d4ee.tar.xz
testing/py-xmpppy new abuild
Diffstat (limited to 'testing/py-xmpppy')
-rw-r--r--testing/py-xmpppy/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/py-xmpppy/APKBUILD b/testing/py-xmpppy/APKBUILD
new file mode 100644
index 0000000000..a9a3b01100
--- /dev/null
+++ b/testing/py-xmpppy/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=py-xmpppy
+_pkgname=xmpppy
+pkgver=0.4.1
+pkgrel=0
+pkgdesc="A Python library to provide easy scripting with Jabber"
+url="http://xmpppy.sourceforge.net/"
+arch="all"
+license="GPL"
+depends="python"
+depends_dev=
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="http://downloads.sourceforge.net/sourceforge/xmpppy/$_pkgname-$pkgver.tar.gz"
+
+_builddir=$srcdir/$_pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ python setup.py build
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p "$pkgdir"/usr/lib/python2.6/site-packages
+ python setup.py install --root="$pkgdir"
+}
+
+md5sums="ca36d685643f2c56ab07323a09ece9e4 xmpppy-0.4.1.tar.gz"