aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py2-linecache2
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2017-07-25 00:11:55 +0000
committerJakub Jirutka <jakub@jirutka.cz>2017-12-14 21:14:04 +0100
commit0c0f3b678a26a747b2878b2e12246bf0bc44a9a6 (patch)
tree6c5718def791aa37b4173bcc91519bd2f791974e /testing/py2-linecache2
parentbbc43ab3bc1711b42e007044e6cad75080a17632 (diff)
downloadaports-0c0f3b678a26a747b2878b2e12246bf0bc44a9a6.tar.bz2
aports-0c0f3b678a26a747b2878b2e12246bf0bc44a9a6.tar.xz
testing/py2-linecache2: new aport
Diffstat (limited to 'testing/py2-linecache2')
-rw-r--r--testing/py2-linecache2/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/py2-linecache2/APKBUILD b/testing/py2-linecache2/APKBUILD
new file mode 100644
index 0000000000..87df903b26
--- /dev/null
+++ b/testing/py2-linecache2/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
+# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
+pkgname=py2-linecache2
+_pkgname=${pkgname#py2-*}
+pkgver=1.0.0
+pkgrel=0
+pkgdesc="Backport of the Python3 stdlib linecache module"
+url="https://github.com/testing-cabal/linecache2"
+arch="noarch"
+license="PSF"
+depends="python2"
+makedepends="python2-dev py-setuptools"
+options="!check" # temp disable until py2-unittest2 is in repos
+#checkdepends="py2-fixtures py2-unittest2 py2-traceback2 py2-six py2-pbr py2-testtools py2-extras"
+source="$pkgname-$pkgver.tar.gz::https://github.com/testing-cabal/$_pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python2 -m unittest2 discover
+}
+
+package() {
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="02163afa1dcaebd4c22e7195b9cbcd0d301d5920ff18310c2addf6563edf93e386daf642a560d8158cad25c2f5547c8ee23ec3a5490d3d54323f47adeea3e8df py2-linecache2-1.0.0.tar.gz"