aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py2-unittest2
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2017-07-25 00:12:21 +0000
committerJakub Jirutka <jakub@jirutka.cz>2017-12-14 21:14:06 +0100
commitd128be4fb1188adcb594a9ea57b075f570b46c86 (patch)
tree4470b85997a5c661495056c088f810b70d3e5803 /testing/py2-unittest2
parent0c0f3b678a26a747b2878b2e12246bf0bc44a9a6 (diff)
downloadaports-d128be4fb1188adcb594a9ea57b075f570b46c86.tar.bz2
aports-d128be4fb1188adcb594a9ea57b075f570b46c86.tar.xz
testing/py2-unittest2: new aport
Diffstat (limited to 'testing/py2-unittest2')
-rw-r--r--testing/py2-unittest2/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/py2-unittest2/APKBUILD b/testing/py2-unittest2/APKBUILD
new file mode 100644
index 0000000000..a0c55853ad
--- /dev/null
+++ b/testing/py2-unittest2/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
+# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
+pkgname=py2-unittest2
+_pkgname=${pkgname#py2-*}
+pkgver=1.1.0
+pkgrel=0
+pkgdesc="Backport of the Python3 enhanced unittest testing framework"
+url="https://pypi.python.org/pypi/unittest2"
+arch="noarch"
+license="PSF"
+depends="py2-six py2-argparse py2-traceback2 py2-linecache2"
+makedepends="python2-dev py-setuptools"
+source="$pkgname-$pkgver.tar.gz::http://http.debian.net/debian/pool/main/u/$_pkgname/${_pkgname}_${pkgver}.orig.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python2 -m unittest2 discover
+}
+
+package() {
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="3fba15728905f437767416ab4fd3573d3fb2319486ef84c52a9fa930ea84aa1f2ae29d6f58993e3509083625790e17b1ef8d9ac5de0e166c254897a3e7a202fa py2-unittest2-1.1.0.tar.gz"