aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-ansi2html
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-03-30 00:14:15 +0200
committerprspkt <prspkt@protonmail.com>2019-03-30 00:14:15 +0200
commit37e203e6dfd3a6af5d323b2dfdd237824e3092a1 (patch)
tree8749ebee8258af631f37fa8f0fa381b4ec083747 /testing/py3-ansi2html
parentcfee84f585419a553d461232112c9112f4de8637 (diff)
downloadaports-37e203e6dfd3a6af5d323b2dfdd237824e3092a1.tar.bz2
aports-37e203e6dfd3a6af5d323b2dfdd237824e3092a1.tar.xz
testing/py3-ansi2html: clarify license, modernize
Diffstat (limited to 'testing/py3-ansi2html')
-rw-r--r--testing/py3-ansi2html/APKBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/testing/py3-ansi2html/APKBUILD b/testing/py3-ansi2html/APKBUILD
index b9f6db1b77..4eb96e7fb8 100644
--- a/testing/py3-ansi2html/APKBUILD
+++ b/testing/py3-ansi2html/APKBUILD
@@ -5,28 +5,25 @@ _pkgname=ansi2html
pkgver=1.3.0
pkgrel=0
pkgdesc="Convert text with ANSI color codes to HTML"
-url="http://github.com/ralphbean/ansi2html/"
+url="https://github.com/ralphbean/ansi2html"
arch="noarch"
-license="GPL-3.0-or-later"
+license="LGPL-3.0-or-later"
provides="py-ansi2html" # for backwards compatibility
replaces="py-ansi2html=$pkgver-r$pkgrel" # for backwards compatibility
depends="python3 py3-setuptools py3-six"
-depends_dev=""
makedepends="python3-dev"
-install=""
-subpackages=""
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
build() {
cd "$builddir"
- python3 setup.py build || return 1
+ python3 setup.py build
}
package() {
cd "$builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="73d1b3431e22146c4fe18fef4b05413231d79d627c396d67528d0aa1ab07a7ef4bcfeff56829b85d9fe9ad508599b782318911f7b10d6b9a1bc98780e31389d7 ansi2html-1.3.0.tar.gz"