aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-ask
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 14:13:56 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 14:28:06 -0300
commitcf4f900cfa277172fdf683ef8f8a19eb79c94351 (patch)
tree63499b2ca1ee558aa8b6aa6c9cafcb1d86b4f9b5 /testing/py3-ask
parentd644619c1599202f0e69c37373a626a287748e99 (diff)
downloadaports-cf4f900cfa277172fdf683ef8f8a19eb79c94351.tar.bz2
aports-cf4f900cfa277172fdf683ef8f8a19eb79c94351.tar.xz
testing/py3-ask: rename from py-ask
Diffstat (limited to 'testing/py3-ask')
-rw-r--r--testing/py3-ask/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/py3-ask/APKBUILD b/testing/py3-ask/APKBUILD
new file mode 100644
index 0000000000..6e4ae0bf5e
--- /dev/null
+++ b/testing/py3-ask/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-ask
+_pkgname=ask
+pkgver=0.0.8
+pkgrel=0
+pkgdesc="An easy input validation for Python"
+url="https://github.com/chive/ask"
+arch="noarch"
+license="MIT"
+depends="python2"
+depends_dev=""
+makedepends="python2-dev py-setuptools"
+install=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="8258349066a4f57d1a5e7a136cca8330e662e135ac366b905327e9c3535ec1a949865cf20e1332d9f8a22d06c76474f86cdbd11e52bf7c002e87a3f3654ded60 ask-0.0.8.tar.gz"