aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-blinker
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-08-22 01:00:03 +0300
committerprspkt <prspkt@protonmail.com>2019-08-22 01:02:25 +0300
commit3f93e0372812e6d4d4ad9294acb427e1f3135fd2 (patch)
tree2de150d67c9430c26787b1992e348a8c7546d420 /testing/py3-blinker
parent48dc02fcfc8aea4034a584dca99fc2f566d6141c (diff)
downloadaports-3f93e0372812e6d4d4ad9294acb427e1f3135fd2.tar.bz2
aports-3f93e0372812e6d4d4ad9294acb427e1f3135fd2.tar.xz
testing/py3-blinker: add checkdepends, run test suite
* Adopt package. * Update url to https. Signed-off-by: prspkt <prspkt@protonmail.com>
Diffstat (limited to 'testing/py3-blinker')
-rw-r--r--testing/py3-blinker/APKBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/testing/py3-blinker/APKBUILD b/testing/py3-blinker/APKBUILD
index 82e8986475..9036d990fb 100644
--- a/testing/py3-blinker/APKBUILD
+++ b/testing/py3-blinker/APKBUILD
@@ -1,16 +1,16 @@
-# Contributor:
-# Maintainer:
+# Contributor: prspkt <prspkt@protonmail.com>
+# Maintainer: prspkt <prspkt@protonmail.com>
pkgname=py3-blinker
_pkgname=blinker
pkgver=1.4
pkgrel=4
pkgdesc="Fast, simple object-to-object and broadcast signalling"
-options="!check" # Tests don't run with setup.py test and no instructions to run them
-url="http://pypi.python.org/pypi/blinker"
+url="https://pypi.python.org/pypi/blinker"
arch="noarch"
license="MIT"
depends="python3"
makedepends="py3-setuptools"
+checkdepends="py3-nose"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -18,6 +18,10 @@ build() {
python3 setup.py build
}
+check() {
+ PYTHONPATH="$builddir/build/lib" nosetests
+}
+
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}