aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-cleo
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-02 02:47:53 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-06-02 16:20:34 +0000
commitce9d87fe30f684ace09a623bf39d767539967649 (patch)
tree1a561c592d73ae8cd8a629ee6c7c251ecfe4c124 /testing/py3-cleo
parent9f3675e75f69b8ecb5c660b35268ce0536d7cf33 (diff)
downloadaports-ce9d87fe30f684ace09a623bf39d767539967649.tar.bz2
aports-ce9d87fe30f684ace09a623bf39d767539967649.tar.xz
testing/py3-cleo: new aport
Python3 to create beautiful and testable command-line interfaces https://github.com/sdispater/cleo Closes GH-8381
Diffstat (limited to 'testing/py3-cleo')
-rw-r--r--testing/py3-cleo/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/py3-cleo/APKBUILD b/testing/py3-cleo/APKBUILD
new file mode 100644
index 0000000000..beae311985
--- /dev/null
+++ b/testing/py3-cleo/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-cleo
+_realname=cleo
+pkgver=0.6.8
+pkgrel=0
+pkgdesc="Python3 library to create beautiful and testable command-line interfaces"
+options="!check" # No tests on pypi tarball, github uses pyproject.toml
+url="https://github.com/sdispater/cleo"
+arch="noarch"
+license="MIT"
+depends="python3 py3-pastel py3-pylev py3-clikit"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_realname:0:1}/$_realname/$_realname-$pkgver.tar.gz"
+builddir="$srcdir/$_realname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="944f65e5608329a4715afcdb76d1f5dfec188a886d8f5e907fa03b3d3c9594b9a61679cceb7fddcdc2c62655a9acb015b36cac04b6ab0ef131fe62cade350a60 cleo-0.6.8.tar.gz"