aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-click-plugins/APKBUILD
diff options
context:
space:
mode:
authorHolger Jaekel <holger.jaekel@gmx.de>2019-12-15 00:17:58 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-15 16:40:38 +0100
commitf7ba2a78332cfae86eee99f7df9c7182bdd8e692 (patch)
tree5d205c548c0686bca42a064756dddbecf03da5bb /testing/py3-click-plugins/APKBUILD
parent82e200f049158f00976180ea40de2adbc0942681 (diff)
downloadaports-f7ba2a78332cfae86eee99f7df9c7182bdd8e692.tar.bz2
aports-f7ba2a78332cfae86eee99f7df9c7182bdd8e692.tar.xz
testing/py3-click-plugins: new aport
https://pypi.org/project/click-plugins/ An extension module for click to enable registering CLI commands via setuptools entry-points
Diffstat (limited to 'testing/py3-click-plugins/APKBUILD')
-rw-r--r--testing/py3-click-plugins/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/py3-click-plugins/APKBUILD b/testing/py3-click-plugins/APKBUILD
new file mode 100644
index 0000000000..0d247fb50c
--- /dev/null
+++ b/testing/py3-click-plugins/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Holger Jaekel <holger.jaekel@gmx.de>
+# Maintainer: Holger Jaekel <holger.jaekel@gmx.de>
+_pkgname=click-plugins
+pkgname=py3-$_pkgname
+pkgver=1.1.1
+pkgrel=0
+pkgdesc="An extension module for click to enable registering CLI commands via setuptools entry-points"
+url="https://pypi.org/project/click-plugins/"
+arch="noarch"
+license="BSD-3-Clause"
+depends="
+ python3
+ py3-click
+ "
+checkdepends="
+ pytest
+ "
+source="
+ py3-click-plugins-$pkgver.tar.gz::https://github.com/click-contrib/click-plugins/archive/$pkgver.tar.gz
+ "
+builddir="$srcdir/click-plugins-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ pytest-3
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir" --optimize=2
+}
+
+sha512sums="a1735f493aad45b328e3156b239376be89ae8bc9d1cd349355496352157672b6642429e0fe7e364c0e971c5f347263cfb6481f413185ad869173c2777679a37e py3-click-plugins-1.1.1.tar.gz"