aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-commonmark
diff options
context:
space:
mode:
authorRobert Sacks <robert@sacks.email>2019-07-05 15:40:29 -0400
committerLeo <thinkabit.ukim@gmail.com>2019-11-29 17:53:09 +0100
commitf20a2850f824cb7e93e17d647ea9bd1fadf9e19e (patch)
tree8bdba07a1435391baaf31c0de408d48d159f34dd /testing/py3-commonmark
parent469315fdda2e6af0cc1263913753359c833f0ef9 (diff)
downloadaports-f20a2850f824cb7e93e17d647ea9bd1fadf9e19e.tar.bz2
aports-f20a2850f824cb7e93e17d647ea9bd1fadf9e19e.tar.xz
testing/py3-commonmark: new aport
https://pypi.org/project/commonmark/ Python parser for the CommonMark Markdown specification
Diffstat (limited to 'testing/py3-commonmark')
-rw-r--r--testing/py3-commonmark/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/py3-commonmark/APKBUILD b/testing/py3-commonmark/APKBUILD
new file mode 100644
index 0000000000..c57a78e224
--- /dev/null
+++ b/testing/py3-commonmark/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Robert Sacks <robert@sacks.email>
+# Maintainer: Robert Sacks <robert@sacks.email>
+pkgname=py3-commonmark
+_pyname=commonmark
+pkgver=0.9.0
+pkgrel=0
+pkgdesc="Python3 parser for the CommonMark Markdown specification"
+url="https://pypi.org/project/commonmark/"
+arch="noarch"
+license="BSD-3-Clause"
+depends="python3 py3-future"
+makedepends="py3-setuptools"
+checkdepends="py3-hypothesis py3-flake8"
+source="https://files.pythonhosted.org/packages/source/${_pyname%${_pyname#?}}/$_pyname/$_pyname-$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ PYTHONPATH="$PWD/build/lib" python3 commonmark/tests/unit_tests.py
+ PYTHONPATH="$PWD/build/lib" python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="f5cb6c9a32fdb441a229b70118652c0fd1b0f058728c594966f5fe04a58ec005feaade49fa72f3aa07b3376e4148e76203313e4f14d29fc86f2acc125533a4fa commonmark-0.9.0.tar.gz"