aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-curio/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-03-27 18:35:07 +0100
committerRasmus Thomsen <oss@cogitri.dev>2020-05-06 20:36:43 +0000
commitbf394997c332e8b46055bbc216c2f6f036848b30 (patch)
treeafe63d3bbd5a610d1e5b2d3bbd7f952405d62516 /testing/py3-curio/APKBUILD
parent12db2976fccd9ca7e5852ee57818014ba4299432 (diff)
downloadaports-bf394997c332e8b46055bbc216c2f6f036848b30.tar.bz2
aports-bf394997c332e8b46055bbc216c2f6f036848b30.tar.xz
testing/py3-curio: new aport
Diffstat (limited to 'testing/py3-curio/APKBUILD')
-rw-r--r--testing/py3-curio/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py3-curio/APKBUILD b/testing/py3-curio/APKBUILD
new file mode 100644
index 0000000000..48c5d92c51
--- /dev/null
+++ b/testing/py3-curio/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=py3-curio
+pkgver=1.1
+pkgrel=0
+pkgdesc="Curio is a coroutine-based library for concurrent systems programming"
+url="https://github.com/dabeaz/curio"
+arch="noarch"
+license="BSD-3-Clause"
+depends="python3"
+makedepends="py3-setuptools py3-sphinx"
+checkdepends="py3-pytest"
+source="https://pypi.python.org/packages/source/c/curio/curio-$pkgver.tar.gz"
+options="!check" # No tests
+builddir="$srcdir/curio-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="88e14775a4fa2a8285a96a6493d53c95bed0b7a027612f755ce7c1fcbea11cd81aedf916c021e03084573f4df146aee9fb26d272193143f8ec7fbb5609a7d0fe curio-1.1.tar.gz"