aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-discogs-client
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-03-25 23:19:21 +0200
committerprspkt <prspkt@protonmail.com>2019-03-25 23:47:16 +0200
commit3cd9ca2e879309bce9363696881102dc088b2859 (patch)
tree9441eb8a6b3f5495057ca8c63205cc6e711220ae /testing/py3-discogs-client
parent0fecfacdab651d1bbac982a9a5ead265b7b93af8 (diff)
downloadaports-3cd9ca2e879309bce9363696881102dc088b2859.tar.bz2
aports-3cd9ca2e879309bce9363696881102dc088b2859.tar.xz
testing/py-discogs-client: upgrade to python3
- add py3-oauthlib and py3-six depends
Diffstat (limited to 'testing/py3-discogs-client')
-rw-r--r--testing/py3-discogs-client/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-discogs-client/APKBUILD b/testing/py3-discogs-client/APKBUILD
new file mode 100644
index 0000000000..27d4a75cc4
--- /dev/null
+++ b/testing/py3-discogs-client/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=py3-discogs-client
+_pkgname=discogs-client
+pkgver=2.2.2
+pkgrel=0
+pkgdesc="Official Python API client for Discogs"
+url="https://github.com/discogs/discogs_client"
+arch="noarch"
+license="BSD-2-Clause"
+provides="py-discogs-client" # for backwards compatibility
+replaces="py-discogs-client=$pkgver-r$pkgrel" # for backwards compatibility
+depends="python3 py3-requests py3-oauthlib py3-six"
+makedepends="python3-dev py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="cf08526f739216efa9ef628f28650c8074cd6ddb21e0ab5431a8c8864c1f2707f612b065baf6b2f907b7fa7cdf2cfe5905cbefddb02c6f8f1c7796b0631a2ba7 discogs-client-2.2.2.tar.gz"