aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-distorm3/APKBUILD
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-24 18:15:48 +0300
committerprspkt <prspkt@protonmail.com>2019-06-24 18:41:43 +0300
commit9c1280dbe099775b089bd67c5fe7fb9127bb64a2 (patch)
tree78b6667de3308e106e05e6239a39671404fea927 /testing/py3-distorm3/APKBUILD
parent6ad30d7e57a9023d45dc9a9d6612715d3fd2a4a2 (diff)
downloadaports-9c1280dbe099775b089bd67c5fe7fb9127bb64a2.tar.bz2
aports-9c1280dbe099775b089bd67c5fe7fb9127bb64a2.tar.xz
testing/py-distorm3: drop python2
Diffstat (limited to 'testing/py3-distorm3/APKBUILD')
-rw-r--r--testing/py3-distorm3/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py3-distorm3/APKBUILD b/testing/py3-distorm3/APKBUILD
new file mode 100644
index 0000000000..14603327fc
--- /dev/null
+++ b/testing/py3-distorm3/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=py3-distorm3
+_pkgname=distorm3
+pkgver=3.3.4
+pkgrel=1
+pkgdesc="The goal of diStorm3 is to decode x86/AMD64 binary streams and return a structure that describes each instruction"
+url="https://pypi.python.org/pypi/distorm3"
+arch="all"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+source="https://github.com/gdabah/distorm/releases/download/v$pkgver/distorm3-$pkgver.zip"
+builddir="$srcdir/${pkgname/py3-/}-$pkgver"
+
+replaces="py-distorm3" # Backwards compatibility
+provides="py-distorm3=$pkgver-r$pkgrel" # Backwards compatibility
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="ac989fcbfa857f86fa5cd6c054a2f5e7bd2d7ccaf345950062dd70542e5e4ae5d179cda58e721f54b889549c63cbdfc6ed985a35f767dbbd3db4577fdc592ec6 distorm3-3.3.4.zip"