aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-distributed
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-03-27 13:08:39 +0100
committerRasmus Thomsen <oss@cogitri.dev>2020-05-06 20:36:42 +0000
commit36dd174f6f344c2dc56ca8ba8e67a22aef92b488 (patch)
tree6d14b5910cfb974e10b94c1bb625f14c153e1b53 /testing/py3-distributed
parent7f18e44c38072b470574c8f14edd3f1df1faef3c (diff)
downloadaports-36dd174f6f344c2dc56ca8ba8e67a22aef92b488.tar.bz2
aports-36dd174f6f344c2dc56ca8ba8e67a22aef92b488.tar.xz
testing/py3-distributed: new aport
Diffstat (limited to 'testing/py3-distributed')
-rw-r--r--testing/py3-distributed/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/py3-distributed/APKBUILD b/testing/py3-distributed/APKBUILD
new file mode 100644
index 0000000000..551ad392da
--- /dev/null
+++ b/testing/py3-distributed/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=py3-distributed
+pkgver=2.15.2
+pkgrel=0
+pkgdesc="A library for distributed computation"
+url="https://distributed.dask.org/"
+arch="noarch !mips !mips64 !s390x" # Blocked by py3-dask
+license="BSD-3-Clause"
+depends="python3"
+depends="py3-dask py3-yaml py3-tornado py3-tblib py3-click py3-cloudpickle py3-msgpack py3-psutil py3-sortedcontainers py3-zict"
+makedepends="py3-setuptools python3-dev linux-headers yaml-dev"
+checkdepends="py3-pytest py3-pytest-asyncio py3-requests py3-paramiko py3-arrow py3-h5py py3-scipy py3-lz4 py3-jsonschema"
+source="https://pypi.python.org/packages/source/d/distributed/distributed-$pkgver.tar.gz"
+# Tests are flaky
+# Net required for tests
+options="!check"
+builddir="$srcdir/distributed-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ PYTHONPATH="$PWD/build/lib" pytest
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="e68658d090a5fd29f127e1e43619b4531f9d04f69bcf288c02aea1fa7f7f5427b91d9c42ee9d01107f5c9d5f8807cb81e79425ba26ced5ac4fde7976414f5531 distributed-2.15.2.tar.gz"