aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-django-cors-headers/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-20 17:23:35 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-20 17:23:35 -0300
commit681302b05cdbf20fa00afe02ad6975fa6dddded9 (patch)
treec97b3e641c5f8c57651be9fb039d1d201ca6bb65 /testing/py3-django-cors-headers/APKBUILD
parent5c75418589681eba4be9c99b6d5dbdbbcd8a2342 (diff)
downloadaports-681302b05cdbf20fa00afe02ad6975fa6dddded9.tar.bz2
aports-681302b05cdbf20fa00afe02ad6975fa6dddded9.tar.xz
testing/py3-django-cors-headers: upgrade to 3.0.2
Diffstat (limited to 'testing/py3-django-cors-headers/APKBUILD')
-rw-r--r--testing/py3-django-cors-headers/APKBUILD54
1 files changed, 14 insertions, 40 deletions
diff --git a/testing/py3-django-cors-headers/APKBUILD b/testing/py3-django-cors-headers/APKBUILD
index 4570865544..7d04b84e2f 100644
--- a/testing/py3-django-cors-headers/APKBUILD
+++ b/testing/py3-django-cors-headers/APKBUILD
@@ -1,56 +1,30 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer:
-pkgname=py-django-cors-headers
-pkgver=2.4.0
-pkgrel=1
+pkgname=py3-django-cors-headers
+_pkgname=django-cors-headers
+pkgver=3.0.2
+pkgrel=0
pkgdesc="Django app for handling the server headers required for Cross-Origin Resource Sharing (CORS)"
+options="!check" # Requires running django instance
url="https://github.com/OttoYiu/django-cors-headers"
arch="noarch"
-license="Custom"
-depends="py-django"
-makedepends="python2-dev python3-dev py-setuptools"
-checkdepends="py-django py-tz py-mock pytest"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-options="!check" # FIXME: fail
-source="$pkgname-$pkgver.tar.gz::https://github.com/ottoyiu/django-cors-headers/archive/$pkgver.tar.gz"
-builddir="$srcdir"/django-cors-headers-$pkgver
+license="MIT"
+depends="py3-django"
+makedepends="py3-setuptools"
+checkdepends="py3-tz py3-mock py3-pytest py3-coverage py3-pytest-cov"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ottoyiu/$_pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$builddir"
- python2 setup.py --quiet build
python3 setup.py --quiet build
}
-package() {
- cd "$builddir"
- mkdir -p "$pkgdir"/usr/bin
-}
-
check() {
- cd "$builddir"
- python2 runtests.py ./tests
python3 runtests.py ./tests
}
-_py2() {
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-_py() {
- local python="$1"
- local pyver="${1:6:1}"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py --quiet install --prefix=/usr --root="$subpkgdir"
+package() {
+ python3 setup.py --quiet install --prefix=/usr --root="$pkgdir"
}
-sha512sums="97f12655b0f499e62fbee6b506703fe9a43988f5d5ab275eb16ce8429c221fab6f8c50670357b33f218686490ae1a54527743a32d3a796c333dcb6328db4b94e py-django-cors-headers-2.4.0.tar.gz"
+sha512sums="fb8a1f2981b9cc6ca8c2e24a926d49b84500cac270e362f39617ce3b95337aefb156fca89c9aea06bc94b5a8adb9591e5cecfc76caa67e6f6858d09928bf4b7d py3-django-cors-headers-3.0.2.tar.gz"