aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-django-timezone-field
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-20 16:49:16 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-20 16:49:16 -0300
commitd5bdd5bb2b87e2ac46277bf82150b289031fcc39 (patch)
tree9478dbbf3967e1ef3a29b33505e3b27b4cf93511 /testing/py3-django-timezone-field
parent510613b01dcd0d9b583e3515c9069d13c0937891 (diff)
downloadaports-d5bdd5bb2b87e2ac46277bf82150b289031fcc39.tar.bz2
aports-d5bdd5bb2b87e2ac46277bf82150b289031fcc39.tar.xz
testing/py3-django-timezone-field: rename from py-django-timezone-field
Diffstat (limited to 'testing/py3-django-timezone-field')
-rw-r--r--testing/py3-django-timezone-field/APKBUILD55
1 files changed, 55 insertions, 0 deletions
diff --git a/testing/py3-django-timezone-field/APKBUILD b/testing/py3-django-timezone-field/APKBUILD
new file mode 100644
index 0000000000..d31ff66362
--- /dev/null
+++ b/testing/py3-django-timezone-field/APKBUILD
@@ -0,0 +1,55 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer:
+pkgname=py-django-timezone-field
+pkgver=3.0
+pkgrel=1
+pkgdesc="A Django app providing database and form fields for pytz timezone objects"
+url="https://pypi.python.org/pypi/django-timezone-field"
+arch="noarch"
+license="BSD"
+depends="py-django py-tz"
+makedepends="python2-dev python3-dev py-setuptools"
+options="!check" #no testsuite
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="$pkgname-$pkgver.tar.gz::https://github.com/mfogel/django-timezone-field/archive/$pkgver.tar.gz"
+builddir="$srcdir"/django-timezone-field-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py --quiet build
+ python3 setup.py --quiet build
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir"/usr/bin
+}
+
+check() {
+ cd "$builddir"
+ python2 tests.py
+ python3 tests.py
+}
+
+_py2() {
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ local pyver="${1:6:1}"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py --quiet install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="00e2df498674c151d53581e0dd8bb5e775d595113a12bfba127d558de1f1b31003fffaa070645a9601266bd2bfe59511e493d0dbcf30e624411a9ff7867d9341 py-django-timezone-field-3.0.tar.gz"