aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-flake8-isort/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-20 12:56:44 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-20 14:50:56 -0300
commita99a5934b5f8549dc126485b8397c10cdcc021f1 (patch)
tree5bdc03978b6ebdff21a6d491f5dbe1d3f57cc46c /testing/py3-flake8-isort/APKBUILD
parentab3a5e91b53258e3293aadfe97f86344dc8994d7 (diff)
downloadaports-a99a5934b5f8549dc126485b8397c10cdcc021f1.tar.bz2
aports-a99a5934b5f8549dc126485b8397c10cdcc021f1.tar.xz
testing/py3-flake8-isort: upgrade to 2.7.0
Diffstat (limited to 'testing/py3-flake8-isort/APKBUILD')
-rw-r--r--testing/py3-flake8-isort/APKBUILD26
1 files changed, 13 insertions, 13 deletions
diff --git a/testing/py3-flake8-isort/APKBUILD b/testing/py3-flake8-isort/APKBUILD
index 9a4708cad3..27193f4ab3 100644
--- a/testing/py3-flake8-isort/APKBUILD
+++ b/testing/py3-flake8-isort/APKBUILD
@@ -1,28 +1,28 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-flake8-isort
+pkgname=py3-flake8-isort
_pkgname=flake8-isort
-pkgver=2.0.1
-pkgrel=2
+pkgver=2.7.0
+pkgrel=0
pkgdesc="Extension for flake8 which integrates isort"
+options="!check" # No testsuite
url="https://github.com/gforcada/flake8-isort"
arch="noarch"
-license="GPL-2.0"
-depends="flake8 py3-isort"
-makedepends="python3-dev"
+license="GPL-2.0-only"
+depends="py3-flake8 py3-isort"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-flake8-isort" # Backwards compatibility
+provides="py-flake8-isort=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- cd "$builddir"
- python3 setup.py build || return 1
+ python3 setup.py build
}
package() {
- cd "$builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="06d102adf075c2dc4d4b4dd4dd534b91 flake8-isort-2.0.1.tar.gz"
-sha256sums="9b994a95b3b26552fa25a8b94d7b345aea87ddb8c3bf78e7869b73ecc6088de7 flake8-isort-2.0.1.tar.gz"
-sha512sums="c2d8006ea9dce62c2a990ab9769d65f1e040fcf3931c61b50a8dd208d3fa0037758102d46dafce4342126a38716b4ff3e06d7015a65a20a8458543ae8b2627d3 flake8-isort-2.0.1.tar.gz"
+sha512sums="9f2065ae9b0ed6f630eafdff73c3e35bdd5ef7dd0110b34222d4d695abc32070224d04855d401c8af8f21dda6f89530f527a5f6937adf110e5b8a52ff39ddfed flake8-isort-2.7.0.tar.gz"