aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-flake8-isort
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-20 12:54:56 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-20 14:50:56 -0300
commitab3a5e91b53258e3293aadfe97f86344dc8994d7 (patch)
treec3bb3a6a8a342c9078fd66a1e64a26fc56fffb2f /testing/py3-flake8-isort
parent25bad2a828ee44ca6541ee820e85ddfa8c779e8a (diff)
downloadaports-ab3a5e91b53258e3293aadfe97f86344dc8994d7.tar.bz2
aports-ab3a5e91b53258e3293aadfe97f86344dc8994d7.tar.xz
testing/py3-flake8-isort: rename from py-flake8-isort
Diffstat (limited to 'testing/py3-flake8-isort')
-rw-r--r--testing/py3-flake8-isort/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-flake8-isort/APKBUILD b/testing/py3-flake8-isort/APKBUILD
new file mode 100644
index 0000000000..9a4708cad3
--- /dev/null
+++ b/testing/py3-flake8-isort/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-flake8-isort
+_pkgname=flake8-isort
+pkgver=2.0.1
+pkgrel=2
+pkgdesc="Extension for flake8 which integrates isort"
+url="https://github.com/gforcada/flake8-isort"
+arch="noarch"
+license="GPL-2.0"
+depends="flake8 py3-isort"
+makedepends="python3-dev"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="06d102adf075c2dc4d4b4dd4dd534b91 flake8-isort-2.0.1.tar.gz"
+sha256sums="9b994a95b3b26552fa25a8b94d7b345aea87ddb8c3bf78e7869b73ecc6088de7 flake8-isort-2.0.1.tar.gz"
+sha512sums="c2d8006ea9dce62c2a990ab9769d65f1e040fcf3931c61b50a8dd208d3fa0037758102d46dafce4342126a38716b4ff3e06d7015a65a20a8458543ae8b2627d3 flake8-isort-2.0.1.tar.gz"