aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-flask-basicauth/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-08 14:18:10 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-08 14:25:04 -0300
commit4b7b4073e4860fded30082b7290c7ec2116d33c3 (patch)
treef93be4459df9b37d639e46a992440f31aba38868 /testing/py3-flask-basicauth/APKBUILD
parent2df032bdccbbdbee3cac83671475e04c0d8daa96 (diff)
downloadaports-4b7b4073e4860fded30082b7290c7ec2116d33c3.tar.bz2
aports-4b7b4073e4860fded30082b7290c7ec2116d33c3.tar.xz
testing/py3-flask-basicauth: drop py2
Diffstat (limited to 'testing/py3-flask-basicauth/APKBUILD')
-rw-r--r--testing/py3-flask-basicauth/APKBUILD35
1 files changed, 11 insertions, 24 deletions
diff --git a/testing/py3-flask-basicauth/APKBUILD b/testing/py3-flask-basicauth/APKBUILD
index f4b5376c32..54e3a3ca93 100644
--- a/testing/py3-flask-basicauth/APKBUILD
+++ b/testing/py3-flask-basicauth/APKBUILD
@@ -1,41 +1,28 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-flask-basicauth
+pkgname=py3-flask-basicauth
_pkgname=Flask-BasicAuth
pkgver=0.2.0
-pkgrel=0
+pkgrel=1
pkgdesc="Flask HTTP basic access authentication"
+options="!check" # Broken testsuite
url="https://pypi.python.org/pypi/Flask-BasicAuth"
arch="noarch"
-license="BSD"
-depends="python2 py-flask"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
+license="BSD-3-Clause"
+depends="python3 py3-flask"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+replaces="py-flask-basicauth" # Backwards compatibility
+provides="py-flask-basicauth=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- cd "$_builddir"
- python2 setup.py build || return 1
+ python3 setup.py build
}
package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="6c7d204e06c5133f42e4171cfb2f42e6 Flask-BasicAuth-0.2.0.tar.gz"
-sha256sums="df5ebd489dc0914c224419da059d991eb72988a01cdd4b956d52932ce7d501ff Flask-BasicAuth-0.2.0.tar.gz"
sha512sums="921b05e273e9a4b06f00cb68b68ddca20328f1a3afd1dd779d973792f1382a2bf2c6a8f70719e097dfa3d00d8e511fc35fba218de3fbb8ed6197ddbaa8027f93 Flask-BasicAuth-0.2.0.tar.gz"